0

I have a Iomega SuperSlim USB 2.0 8x DVD Writer External Optical Drive that I used without any issue on my Macbook Air.

Now all of a sudden it doesn't work anymore. The DVD spins, a "Audio CD" item pops up on the Finder sidebar and vanishes a few seconds after. Over and over again.

iTunes manages to get the track info after some attempts, so the DVD is readable.

I've tried to plug the same disc and DVD reader on a Windows machine, it worked seamlessly. So I guess this has something to do with the mac, maybe a recent software update?

Is there anything to do to troubleshoot such issues? It's the first time I have a hardware/driver issue (or similar) on my mac.

HW: MacBook Air 13-inch, early 2014 w/ 8GB or RAM and a Core i7
SW: OS X Yosemite 10.10.3

1

That it works fine on a Windows PC but not your Mac is puzzling.

Think back to when you know it worked properly. What software have you updated since then? That could be the cause. For example if you went from OSX 10.10.3 to 10.10.4 and that is the only change there may have been a problem with the update.

In that case you may want to try re-applying the latest Combo Updater for your current OS version. If it was an app of some sort you may have to contact the manufacturer to see if they have had similar issues from other customers.

  • The problem is I can't pinpoint exactly what changed because it was some time ago. I don't use DVDs a lot, I just wanted to create a backup copy of a music CD I was given recently. I'll try the Combo Updater and see how it goes. Thanks. – Benoit Duffez Jul 27 '15 at 14:58
  • I just went from 10.10.3 to 10.10.4 in the hope of a fix... it's not the case. – Benoit Duffez Jul 29 '15 at 18:13
  • I have seen Macs become 'picky' about hardware as you upgrade. It is possible that the drive has developed a problem that Windows can work around or ignore that Mac OS can or will not. If you have an external drive that you can install an OS on and boot your system with to see if it is OK then that might be worth a try. Failing that there might be an issue with the optical drive. – Steve Chambers Jul 29 '15 at 18:18
-1

Have you tried restarting into the recovery partition and then re-installing OS X?

To restart in recovery mode, shut down or restart your computer, and when it restarts hold down Command R. From there, select Re-install OS X, select your ssd, and let it re-install. It will restart at least once during the process, and when it's done I think the dvd drive will stay mounted.

If that doesn't work, try opening a terminal window (while the dvd drive is plugged in) and typing diskutil list. It should say something list your ssd as disk0, but it should also list the cd as disk1s1 or disk2s1. If it does, that tells you that your computer is able to keep the dvd drive mounted.

And if that doesn't work, your dvd drive may have a problem or is nearing the end of it's life span. Not staying mounted is one of the things that happens when they have problems or are dying

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .