0

From yesterday, every time I type two characters "p" and "i" in serial, it will turn into "ssh pi@10.210.100.45", like this:

And I have checked my system settings System Preferences → Keyboard → Text, it's empty, also unchecked the Correct spelling automatically.

It really confused me, imagine that each time I type "ping some.domain" or some words contains "pi". Does somebody know how can I turn this feature off?

As @Alistair McMillan commented, I post the EtreCheck Result in gist.

  • Perhaps there is something else installed that does text expansion. Run EtreCheck on your Mac, post the results in a gist and add a link to the gist in your original question. This should help us work out what is expanding your text. – Alistair McMillan Jul 25 '15 at 17:34
  • @AlistairMcMillan thanks, I've posted it in my original question. – 2hu Jul 26 '15 at 4:33
  • Thanks for posting the EtreCheck but nothing particularly stands out to me. – Alistair McMillan Jul 27 '15 at 8:54
  • It's hard to tell from the screenshot, which application are you using there? Terminal or something else? – Alistair McMillan Jul 28 '15 at 11:42
  • @AlistairMcMillan terminal and Sublime Text. Just to show that it happens everywhere. – 2hu Jul 30 '15 at 9:39
0

I think I've found the solution to your problem because I was experiencing something similar but with another string of text. Are you using Dash? It's an awesome tool but I didn't realise what it's snippet feature was doing. If you have a snippet called "pi" then whenever that phrase is typed globally across your mac while ever Dash is running, it will substitute it with what is in your snippet. See from the author's page here about a hint to put a ` on the end of snippets to avoid this accidentally occuring.

https://kapeli.com/dash_guide#snippets

Hope this helps!

0

One thing you could check is the Security & Privacy preference pane in System Preferences.

In OS X a lot of applications that hook into keyboard input use the accessibility protocol. They need to ask for permission to do this. If they have then they should be listed against Accessibility under the Security tab of the Accessibility pane.

Example of Accessibility settings in Security & Privacy preference pane

  • When I have unchecked all options in Privacy > Accessibility, the text expansion still works. – 2hu Jul 28 '15 at 9:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .