1

Some context first: I have late 2012 iMac 27" with 1TB fusion drive. Some time ago, for whatever reason, the SSD drive became visible in Disk Utility. I happily used the drive for Yosemite and bootcamp. After some time, for whatever reason, booting became sluggish, so I've reset PRAM. Booting sped up, but SSD went into hiding again, leaving me with no OS. I'd like to go back to the setup with the visible SSD, but I don't know how.

Here are diskutil and gpt outputs:

~ ❯❯❯ diskutil cs list
No CoreStorage logical volume groups found

~ ❯❯❯ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                                                   *0 B        disk0
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:                  Apple_HFS mac                     32.0 GB    disk1s2
   3:                  Apple_HFS home                    20.0 GB    disk1s3
   4:                  Apple_HFS data                    697.9 GB   disk1s4
   5:                  Apple_HFS WIN_DATA                249.6 GB   disk1s5

I think disk0 is the SSD, but why does it have 0B size?

~ ❯❯❯ sudo gpt -vv -r show /dev/disk0                                                                     
gpt show: unable to open device '/dev/disk0': Operation not supported by device

~ ❯❯❯ sudo gpt -vv -r show /dev/disk1                                                                     
gpt show: /dev/disk1: mediasize=1000204886016; sectorsize=512; blocks=1953525168
gpt show: /dev/disk1: PMBR at sector 0
gpt show: /dev/disk1: Pri GPT at sector 1
gpt show: /dev/disk1: Sec GPT at sector 1953525167
       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640    62500000      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
    62909640      262144
    63171784    39062496      3  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
   102234280      262144
   102496424  1363009592      4  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  1465506016      262144
  1465768160   487494824      5  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  1953262984      262151
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header

Here are captures from Disk Utility - the SSD (I guess) is seen as ROM MODE MEDIA, whatever that is: Disk Utility - SSD Disk Utility - SSD info

I tried reinstalling the OS (now I'm using MAC OS 10.8) and formatting the whole disk1, but to no avail. Can someone please help me?


EDIT:

Following @agentroadkill advice I tried the method from 'How to fix deep formatting problems with OS X drives' article. I remember that I tried this method earlier, before posting the question here, and the results were different than described in the article - the /dev/random output was directed to the console then. I don't remember in which boot mode I was in back then. Anyway, I tried it again:

  1. In normal boot mode and in recovery mode:

    sh-3.2# cat /dev/random > /dev/disk0
    cat: stdout: Device not configured
    
  2. In single-user mode:

    :/ root# cat /dev/random > /dev/disk0
    disk0: media is not formatted.
    0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 6] [IOType Read] [PBlkNum 0] [LBlkNum 0] [FSLogMsgID 701182122] [FSLogMsgOrder First]
    0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [DevNode devfs] [MountPt /dev] [Path /dev/disk0] [FSLogMsgID 701182122] [FSLogMsgOrder Last]
    cat: stdout: Device not configured
    
  • You say there is 'no OS', but it looks as though you are booting from the "1 TB APPLE HHD". Could you clarify? – agentroadkill Jul 25 '15 at 23:58
  • Then look here. – agentroadkill Jul 25 '15 at 23:59
  • @agentroadkill yes, now I boot from 'mac' partition on 1TB HDD, but I'd like yo go back to having partitions on the SSD. I'm in trouble as it has 0B size and there's no 'fuse' between HDD and SSD... – u9rZTV9QAc Jul 26 '15 at 9:00
  • Please add the partition scheme history of your "Fusion" drive. Usually (Apple) Fusion drives installed in a Mac are delivered with a CoreStorage partition scheme (a compound of a HDD volume and an SSD volume). It's very unlikely that a decomposed Fusion drives (-> the SSD gets visible suddenly) just works. – klanomath Jul 26 '15 at 13:11
  • @klanomath I had this ROM MODE MEDIA device for a long time (months/years), it appeared with some OS update I think. The drives were fused when the computer shipped in. The SSD became visible when I was repartitioning the HDD and installing Yosemite last month. Then I installed Windows on it (using bootcamp) - it worked. So I moved MAC OS there as well. Everything worked swell on the SSD. Reseting PRAM switched the SSD to ROM MODE MEDIA with 0B. – u9rZTV9QAc Jul 26 '15 at 13:24

You must log in to answer this question.

Browse other questions tagged .