1

I am on OS X 10.10.3 on a macbook Pro. I am using the macbook's keyboard. I have enabled the "Use all F1, F2, etc. keys as standard function keys".

use standard Fn keys

I expect that hitting F1/F2 will not reduce or increase the brightness. But still, the brightness gets changed when I hit F1 or fn+F1.

Is there a way to fix this so I get the following behavior?

Pressing F1 sends just F1 key.

Pressing fn+F1 reduces brightness.

  • Are you using an external keyboard? – mspasov Jul 25 '15 at 10:08
  • This always worked for me. Maybe try a reboot? Also, are you using a Mac keyboard? If you have an external keyboard it might be sending the brightness command itself. – baum Jul 25 '15 at 13:10
  • This is either a question that will not be reproducible, or in has something to do with software settings. Do you use any apps that modify the default key bindings of the software? If yes, then there may be something there that is causing a conflict. If that isn't the case then it may be something that you need to take into an Apple Store or Certified Servicer to take a look at. – AMR Jul 25 '15 at 13:35

You must log in to answer this question.

Browse other questions tagged .