1

Since a couple of days I have problems with the CPU usage of my Safari installation. It runs on OS X Yosemite 10.10.4 (MacBook Pro 13" from 2011).

To reproduce it I only have to open one empty tab and do not need to interact with Safari. After a few seconds the CPU usage goes extremely up. Also the fan is mostly on full speed and the Laptop gets quite hot.

But within that situation if I would open new tabs and browse web content it would work without problems. But then when I want to close Safari it hangs. I can only close it by killing its process.

So I tried analyzing it a bit by having a look at the process:

enter image description here

Here it shows that Safari has 98.4% CPU and a quite huge CPU time of 30:13,03.

I then had a look on what happens inside the process by looking at the call graph, but I did not find anything suspicious (but to be honest I am not a C or Apple expert).

I found some similar articles about Safari CPU problems which are caused by the discoveryd process. But as far as I understood those problems are already solved with Yosemite 10.10.4.

Any ideas about how I could track down the problem and fix my Safari installation?

  • do you have any add ons for Safari ? – Ruskes Jul 24 '15 at 18:52
  • Disabling all extensions was the first thing that I tried. Without success. – h3nrik Jul 24 '15 at 18:54
  • OK, I did not know that. So I assume your tried deleting Cookies, Cache and extension data ? – Ruskes Jul 24 '15 at 19:04
  • Yes. First I deleted only the cookies and cache which did not work. Now I found a way to completely reset my Safari (see my answer). – h3nrik Jul 24 '15 at 19:09
  • Important to note here that that CPU percentage is the percentage of CPU time used, not available. You'd have to look at the system load to verify that Safari is indeed using undue processing resources – agentroadkill Jul 24 '15 at 23:23
11

I found a way to reset my Safari installation this way:

1) I created a backup of my bookmarks:

cp ~/Library/Safari/Bookmarks.plist ~/Desktop/

2) I deleted some Safari specific files:

rm -rf ~/Library/Caches/com.apple.Safari \
       ~/Library/Caches/com.apple.Safari.SearchHelper \
       ~/Library/Caches/Metadata/Safari \
       ~/Library/Cookies/Cookies.binarycookies \
       ~/Library/Cookies/Cookies.plist \
       ~/Library/Preferences/com.apple.Safari.plist \
       ~/Library/Preferences/com.apple.Safari.Extensions.plist \
       ~/Library/Preferences/com.apple.Safari.LSSharedFileList.plist \
       ~/Library/Preferences/com.apple.Safari.RSS.plist \
       ~/Library/PubSub/Database \
       ~/Library/Safari

3) Then I restored my bookmarks:

mkdir ~/Library/Safari && mv ~/Desktop/Bookmarks.plist ~/Library/Safari/Bookmarks.plist

Now the CPU and the fan stay calm.

  • 1
    nice work, a + from me :) – Ruskes Jul 24 '15 at 22:57
  • 1
    I tried multiple things. This one only worked for me. – onekiloparsec Jan 21 '16 at 8:04
1

Had same issue. I disabled plugins under safari preferences / security / plug inns , started up safari, problem gone. I quit safari, enabled the plug ins again , problem remains gone. Magic.

You must log in to answer this question.

protected by Community Mar 5 '17 at 12:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .