0

I have a mid-2009 macbook pro, and the original 10.6.8 installer DVD that it came with. I booted up in recovery mode, and erased the HD (whether or not that was a good idea). My intention was to get rid of old private files, and then update the OS to something current (hopefully 10.10.4), (so the machine could be used in a public setting), using an internet connection while in recovery mode. But I found that the install OS option, while in recovery mode, fails with, "Mac OS X cannot start up from this disk".
I am thinking, "Of course it cannot start up from that disk, because there is nothing on it yet! And how can there be something on it if you will not let me install something!" Argh.
So then I thought maybe I should have 10.6.8 already running (again) on the laptop before I try to update that OS. But then I get the same result, "Mac OS X cannot start up from this disk", when I try to install even 10.6.8 from the original installer disk.

Can anyone better at this level of macs shed light on what I need to do?

  • 2
    Make sure you've formatted the HD to be Macintosh OS Extended (Journaled) and that you've selected the GUID Partition scheme. – IconDaemon Jul 24 '15 at 18:21
2

Start from the original disk, open disk utility and reformat the disk. Then reinstall.

  • I erase the HD, formatted w/extended Journaled, GUID partition map, and then quit disk utils., and then choose the 'reinstall OS' option. Then it offers to install OS X Mavericks. I hit continue and get a dialogue saying it needs to verify my computer's eligibility with Apple. I hit 'continue' and get the message, "An error occurred while preparing the installation. Try running the application again". No amount of repeating the process changes that outcome. – govinda Jul 24 '15 at 23:40
  • I went back and did it again as Kevin says here, but also verified the disk... and even though it verified without need to repair anything, this time it worked. Go figure. – govinda Jul 25 '15 at 2:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .