I have a big issue with my MacBook Pro (OS X 10.10.4). I tried to enable yesterday the TRIM on my SSD disk (a Crucial I replaced myself). Everything was working fine since months but after restarting the laptop because of a Mac update, it got stuck at boot.

I have started on the recovery partition. I have tried all the Terminal commands to revert the TRIM (quite easy: touch, rm, cp,...) but I realized that my disk named "MACBOOK" was not even mounted in /Volumes. So I opened the disk utility and I tried to mount the disk manually but that failed. I checked the disk, it said it had to be fixed. So I tried to fix it, but this failed too.

At this point, I have booted on Disk Warrior that detected an error on the disk: "Invalid record count". Disk Warrior tried to fix it but it went worse: the "MACBOOK" partition has disappeared and a new partition named "Untitled" has appeared. The disk can now be mounted though but seems empty.

So I ran to buy a hard drive dock. I took off the disk from my laptop and plugged it into my brand new dock on my iMac. The disk mounts properly but it is empty. I opened the disk utility and I can see the disk. When displaying all partitions in the Debug menu, I can see this:

Disk Utility

So I see the "Untitled" but also the "MACBOOK". So the partition is still here somewhere. When I click on "Untitled", the disk utility says: Capacity: 510Go Free: 498Go Used: 11,98Go So clearly, Disk Warrior did something nasty like deleting the index table or such as the disk is now considered as empty.

Now, I am using a disaster data recovery tool. It finds thousands of files so the data is still on the disk. But files are not properly named. Like "file00001.png", "file00002.png". That will be very fun to clean all this mess.

I must precise that FileVault is NOT activated on the disk. My mac was running on Yosemite latest version. The ideal would be to fix the permission but at least I'd love to access the disk and get all my folders and file names back. I have a quite recent backup (3 months), I just need to get what has changed in the meantime. I will reinstall afterwards.

I am really getting crazy so any idea would be really appreciated.

Thanks a lot


3 Answers 3


Sory to say that it looks like you had a major disk crash of some sort. If Disk Utility can't fix it and Diskwarrior also can't repair it it is likely that some or all of your data is corrupted/damaged or just plain gone.

The file names you mention "file000001.png" and the like are indicative of some serious issue and the files on your drive have been assigned alternate names just to show you that they are there. they can probably be opened (probably) but it is unlikely the original name is anywhere to be found. it is also likely that the same has happened to all the files on the HD.

A professional data recovery specialist might be able to restore the disk or get you an image of the disk but that kind of service is very expensive. If you can get these files off the drive, I would do so, especially if you don't have a backup.

I hate to be the bearer of bad news but your description of your symptoms don't paint a pretty picture. Hopefully you have a backup. If so, wipe the drive and restore the OS and your files.


What you currently are doing is correct. In this case it is a good idea to quickly restore EVERY file you can find through a file recovery program. You are very lucky that the data was not completely erased. DO NOT WRITE anything else to the disc, as you risk loosing more data.

In my personal experience restoring lost data, I usually: 1. Backup ALL Data I can recover to an External HDD. 2. Restore from a Time Machine Backup. 3. Look for missing Data. 4. Copy from External HDD

Which is basically what you said above. There is no other way to recover all the data quickly. Good luck.

  • Thanks. I knew this was very bad but I wanted confirmation :-(
    – Axel
    Jul 23, 2015 at 16:39
  • PS: next time I use Chameleon SSD, I'll make a bloody backup. Actually, I'm not sure I'm gonna use Chameleon again in my life.
    – Axel
    Jul 23, 2015 at 16:43
  • Do a Google search for Chamelon SSD. I found a couple of links that may have also had some issues with this bit of software, mostly on macrumors.com. IMHO any time I come across a potentially intersting/useful utility, especially one that modifies or "optimizes" OSX. I do a lot of googling. Just sayin'... Jul 23, 2015 at 18:54

I would suggest that you first check the S.M.A.R.T. values of the hard drive, either by booting from a live CD (e.g. Parted Magic) or if you have access to a Windows computer, putting the drive in an external enclosure and checking with tools like HD Tune or HD Sentinel.

Amongst common errors, reallocated sectors will indicate the presence of bad sectors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .