1

Okay, so I've been struggling with this conflict for days now, and I can't figure out how to fix it. Something happened with the way iOS, Mac OS, and GMail has set up 2-step verification and app-specific passwords that has broken my ability to access/read email across my devices.

The only solution I have been able to find is to disable 2-step verification on all my GMail accounts. This is not ideal for obvious reasons.

Currently I am running:

  • iOS 8.4
  • MacOS 10.9.5
  • Apple Mail 7.3

The above version of iOS doesn't support app-specific passwords when I add my GMail account. It redirects me to GMail's login and asks for my Google account password. However, Apple Mail will not accept my Google account password and requires an app-specific password when 2-step verification is turned on. I can generate such a password easily, and it works in Apple Mail. But when I sync between my computer and phone, the result is a conflict where I can receive mail on one device but not the other, because the computer is expecting that the account has only ONE password associated with it.

The weird thing is that it has been working until only relatively recently--like last week, it just broke for reasons I can't figure out.

  • I also have this problem since El Capitan that I just upgraded to. Did you get anywhere on this? – MiB Feb 22 '16 at 6:36
1

https://myaccount.google.com/lesssecureapps

You probably need to enable access for less secure apps Late answer I know but I had the same and it's taken hours to find the fix today

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .