I enabled the TRIM for my SSD on my MacbookPro using Chameleon SSD, and now the Mac doesn't boot any longer. I have tried to follow guides to reverse the TRIM but none of them actually work because my disk appears to be not mounted and does not appear in /Volumes/

When I open the Disk utility, the disk is greyed. If I try to mount it, I get an error : Try repairing the disk. And of course, when I run a repair, it fails too.

Sadly I have no recent backup (of course, would be too easy).

How can I mount this volume and reverse the TRIM enable?

  • Please can you tag in your OS version - Thanks.
    – stuffe
    Jul 23, 2015 at 10:05
  • Do you use Filevault2 / full disk encryption? If you are not sure, what does diskutil cs list yield in terminal?
    – n1000
    Jul 23, 2015 at 11:08
  • and out of curiosity: what SSD do you use?
    – n1000
    Jul 23, 2015 at 12:06
  • Hello, I am using Yosemite latest version. FileVault is disabled, no encryption.
    – Axel
    Jul 23, 2015 at 12:48
  • I have used the Disk Warrior utility to fix the partition. Unfortunately, it has cleared the MACBOOK partition and replaced it by Untitled. I removed the drive from the Macbook and plugged it on a dock on my IMac; here what I see: s4.postimg.org/ct0sthczt/Capture_d_cran_2015_07_23_14_50_18.png The MACBOOK partition is greyed out. Cannot mount it
    – Axel
    Jul 23, 2015 at 12:49

2 Answers 2


Don't panic! I hope you haven't done irreparable damage with the disk utilities and partitioning, which has nothing to do with the problem. The fix is actually very simple.

The grey screen is caused by the non-signed kernel driver for the SSD. Mac OS X won't allow it to load by default, thus you can't access the boot disk.

This can happen if you don't turn off the kernel signing check, or if it gets turned on, which it often does during a system update.

If you are using Trim Enabler, this article describes how to recover. A similar procedure should work for anything that turned on trim.

I'm using a Crucial SSD too, with trim enabled. I forgot to turn Trim off before a system update, and had to recover using the instructions on the linked page (successfully).

Basically it overrides the kernel signing check once again, so you can boot your Mac like before.


Once I was back in, I used the trimforce command to prevent the problem in the future ;-) Trimforce is new in Yosemite, I believe.

  • An earlier version of my answer proposed the same thing. But it seems the problem here goes deeper than that. OP cannot mount his Volume anymore...
    – n1000
    Jul 24, 2015 at 11:54

Did you try fsck as described in this article?

  1. Press cmd + S at startup to boot single-user mode
  2. In terminal /sbin/fsck -fy

If single-user mode doesn't work, try this answer:

  1. In terminal: df -hl to find the disk in question.
  2. then do sudo fsck_hfs -l /dev/disk?

NB: As described here, OS X provides since 10.10.4 a new tool called trimforce, allowing users to activate TRIM also on unsupported disks. No more dangerous experiments with third party software necessary.

  • I have tried the fsck_hfs with -d (for repair) but repair fails.
    – Axel
    Jul 23, 2015 at 13:04
  • @Axel I fell we are running out of options here. Maybe someone else has more ideas. What SSD do you have? There are some disks that do not properly support TRIM and might start writing garbage if activated.
    – n1000
    Jul 23, 2015 at 13:07
  • It's a Crucial SSD 500Go. The disk itself works. I'm trying a data recovery on it. I can see the partition, I just have to figure a way to mount it or fix it
    – Axel
    Jul 23, 2015 at 13:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .