0

For some reason, on my iMac, [alt]+3 will enter the # symbol as it's supposed to in some applications (e.g. Xcode), while in others (e.g. Safari, Terminal...) it just makes a little error 'beep'.

It's not a major problem, since I can use a different key layout and the problem is resolved, but it's always bugged me that I couldn't determine the source of this behaviour. It has persisted through Mountain Lion, Mavericks, Yosemite.

I also have a Macbook Pro with mostly similar configuration and things installed AFAIK, but it doesn't have this problem.

  • I do not have this problem on my MBP as well. In Terminal, you could perhaps go to Preferences > Encoding and enable UTF-8 etc. You can do the same in Safari > Preferences > Advanced > Default Encoding – John K Jul 21 '15 at 13:33
  • Thanks for the suggestion; doesn't seem to make a difference in Safari, Terminal already had UTF-8 along with lots of others (the defaults)... I haven't tried unchecking others. The thing is, they're willing to accept the character, but not via the standard alt+3 with the standard keyboard layout. – PeterT Jul 21 '15 at 14:15
  • Also make sure that you don't have alt-3 as some sort of shortcut. You can check in System Prefs > Keyboard > Shortcuts – John K Jul 21 '15 at 14:16
  • A workaround would be to chnage the keyboard setting to Australian see stackoverflow.com/questions/3977069/emacs-question-hash-key/… – mmmmmm Jul 21 '15 at 14:45
  • Checking keyboard shortcuts was another good suggestion, but no dice (I think I'd already looked there a while ago). I am now using a custom keyboard map which is identical to standard British but with § mapped to #, so it's working ok, just would still like to understand why this happened. – PeterT Jul 21 '15 at 15:02

You must log in to answer this question.

Browse other questions tagged .