1

I'm trying to transfer my information from a mid-2012 Macbook Pro Retina running the latest version of Yosemite (10.10.3). The new machine is a 2015 Retina also running Yosemite.

The first time round I tried doing this via a Thunderbolt cable. The donor machine was booted into target mode, and on the recipient machine I started up the Migration Assistant and followed all the instructions. When the time remaining bar got down to about a minute, it started to creep back up. Info on the screen

It kept going and going. I left it for an hour and a half (bearing in mind the transfer up until then had taken 20 minutes). It had reached about 17 hours by the time I decided to give up.

I then formatted the drive and reinstalled Yosemite via the Internet. So starting with a clean state I tried again with method 2 which was via a Timemachine backup. This had exactly the same effect. I'm going to leave it overnight in vein hope that something might happen, however I thought that I might as well ask on here to see if there are any suggestions.

This is similar to another question, New Mac Pro: Setup/Migration Assistant never finishes, and one piece of advice from that is that I should just boot into target mode and manually copy files over. I may well end up doing that, although obviously I don't want to miss anything.

  • actually Apple says >>Open Migration Assistant, click Continue, then follow the onscreen instructions to transfer info from a Mac.<< >>Open Migration Assistant on the "other Mac", then follow the onscreen instructions to transfer info to a Mac<< – Ruskes Jul 20 '15 at 17:10
  • @Buscar웃SD that didn't work. Couldn't seem to find the donor Mac on the Thunderbolt cable. Target mode should be no different – CircularRecursion Jul 20 '15 at 17:18
  • No. Method two was via Ethernet to a time capsule. – CircularRecursion Jul 20 '15 at 17:45
  • is your disk encrypted on donor ? – Ruskes Jul 20 '15 at 17:52
  • Nope. I've ended up just leaving it in target mode and manually copying stuff over. Bit annoying but done now. – CircularRecursion Jul 20 '15 at 21:26
1

I'd have taken both machines up to 10.10.4 first using the combo updater - as it specifically includes fixes for Migration Assistant.

Then I'd have followed the instructions rather than try it in target disk mode - you need to be running Migration Assistant on both machines, as you must authorise on both.

I've successfully migrated two machines in the past month, one from 10.10.4 to 10.10.4 ...the other from Windows XP… & if it can do that, it can do anything ;-)

  • The Migration Assistant wouldn't recognise the donor machine when connected via a Thunderbolt cable. I did originally follow instructions to the tee. Also the fact that it wouldn't restore via TimeMachine also suggested a problem. – CircularRecursion Jul 22 '15 at 2:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .