0

My girlfriend has a 13-inch Mid 2013 MacBook Air, OS X 10.9.5. Yesterday, the keyboard and the trackpad stopped working. I connected a USB keyboard which works.

I believe it's a software problem because:

  • The Power key still works (all the time)
  • I can boot up in verbose mode (press Command + V while booting)
  • I can do an SMC reset (Shift + Control + Option + Power Up)
  • I can do a PRAM reset (Option + Command + P + R + Power Up)

All these things seem to work with the built-in keyboard, but as soon as the login window appears, the keyboard does not work anymore (except the power button).

Are there any more things I could try? Thanks for your suggestions!

Edit: I just checked the system.log (why didn't I do that earlier?) and the log is FILLED (like 100 messages per second) with these entries:

kernel[0]: Error: AppleHSSPIController::InterruptOccurred Failed to transfer interrupt data with Err (0xe00002eb)
kernel[0]: Error: AppleHSSPIController::doSPITransfer NAK received from device
kernel[0]: Error: AppleHSSPIController::doSPITransfer CRC from device was invalid: computed 0xC03B, received 0x9F7D
  • Does it work in Safe Boot (boot while holding shift) – the eels have eyes Jul 17 '15 at 21:33
  • It boots in safe mode (means it did recognize the shift press), but at the login window still nothing works except USB keyboard and mouse. – Alex Jul 17 '15 at 21:39
  • The boot process starts with generic machine keyboard. After log in system attempts to use the user specified keyboard layout. Did you repair users permissions and disk permissions ? – Ruskes Jul 17 '15 at 21:58
  • I just updated the whole system to Yosemite. Then I tried to repair the disk permissions using the disk utility and then I reset the user permissions using this method: osxdaily.com/2011/11/15/… Sadly still no luck. Keyboard and trackpad not working. – Alex Jul 17 '15 at 22:53
  • If you boot with no USB keyboard, does it show the screen where it suggests changing the batteries in your mouse and keyboard? – the eels have eyes Jul 17 '15 at 22:58
0

Since someone tried to contact me about this issue (he was having the same problem), I will answer my own question.

In the end I took the MacBook to an Apple Shop where they replaced a ribbon cable which solved the problem. Seems like it was a hardware problem after all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .