3

With the kind of writing I do, 99 out of 100 spelling "errors" aren't errors at all. Spell correction is simply incredibly unhelpful for me. I hate the distracting red dotted underline that appears in my native Mac apps.

What system settings can disable this?

I've tried unchecking the available dictionaries, and changing the auto-choose-language vs. specify language ... all through the preferences panel. But even though I've unchecked US English, the system still spell checks automatically with it in apps.

  • 1
    Have you unchecked "Correct spelling automatically" in System Preferences > Keyboard > Text? – aaplmath Jul 17 '15 at 22:09
  • 2
    Yep, because spell correction is disabled. I'm trying to additionally disable spell checking. – Dogweather Jul 17 '15 at 23:43
  • Have you checked out this discussion on Apple Support Communities? discussions.apple.com/thread/2577594 It seems similar to what you have already done, but who knows… – aaplmath Jul 17 '15 at 23:56
  • @aaplmath Yep, I've done that, with only partial effect, and only in some apps. I'm thinking now that it's going to be an app-by-app process. E.g., TextEdit has an app-wide preferences setting to turn this off. But OmniOutliner does not. I'm going to ask over in their forums. – Dogweather Jul 18 '15 at 0:02
-3

Right-click or control-click in the field where you're working and look at the Spelling and Grammar submenu. You can also disable the various substitutions from that submenu.

  • 1
    I find that it disables it only for that particular run of that app. I haven't found any effect on other apps, or when restarting the app. – Dogweather Jul 17 '15 at 23:44
  • Are you having trouble with any other settings not "sticking" between invocations? – the eels have eyes Jul 17 '15 at 23:46
  • Hmm, not that I've noticed. I can run a disk util permissions repair and see if that helps. – Dogweather Jul 17 '15 at 23:49
  • 1
    It's only sticking for that one app because that's the way that setting is designed to work. It's not a system-wide toggle. – aaplmath Jul 17 '15 at 23:50
  • 1
    Well, it doesn't work for me when restarting the app either, once I go to a different "view" within the app (e.g., a new TextEdit document or a new page in Safari). Either both the OP and I are suffering from the same problem, or this is simply not how the setting is designed to work. – aaplmath Jul 17 '15 at 23:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .