I have a SD card that I put into my MacBook Pro. It then showed up in finder. I wanted to access it and I accidentally dragged the mounted card and now it's gone from Finder.

Taking out the card and inserting it again, didn't help. How can I find my SD card drive again?

  • Where did you accidentally drag the SD card icon to? Please edit your question to be more succinct. – IconDaemon Jul 16 '15 at 12:14
  • @IconDaemon, I'd wish I knew. It was kind of an accident that I started dragging, so I let go immediately: I swear that the following animation actually looked like that the SD card device went up in smoke and then it was just gone. – Repox Jul 21 '15 at 5:53
  • Spotlight has probably had its way with the card by now, so try a search for a file you know is on the card, or perhaps the name of the card. If you hold down Command key on Spotlight results, that should show you the path to what you seek. – Wayfaring Stranger Feb 16 '17 at 20:16

11 Answers 11

up vote 11 down vote accepted

In the Finder's sidebar, there should be a section called 'Devices'. Click on the one that's your computer's name and you should see the SD card. Drag it back to the sidebar.

  • 1
    If you don't see your computer's name go to Finder / Preferences / Sidebar to enable it. – Mark-AR Jul 8 '17 at 15:58

I found that removing the SD card, then restarting, then putting the card back in after complete restart worked fine for me.

  • I restarted with the card in and that worked OK, though I took it out and put it back in before the restart to see if it would show up (obviously not). – hBrent Sep 28 '16 at 17:21
  • WARNING you might corrupt data on your SD card if you remove it. That's what happened to me the previous time. I'm going to attempt to reboot leaving the card in, that supposedly should allow any process that accesses the card to exit gracefully. – Morozov Jun 8 at 8:11

Make sure "Show External Disks" is enabled in Finder. Here's how:

Open Finder, Click on 'Finder' on the top bar and select preferences. 'This should bring up the Finder Preferences box. Under the first tab (General) make sure 'External disks' box is ticked. Under the third tab (Sidebar) 'Show these items in the sidebar' scroll down to 'Devices' and make sure the box next to 'External disks' is ticked (though this was probably selected by the first action)

In my case it did not show up because the name was blank. I use disk utility to name it.

I was having this same problem and was able to get the device to show up again by 'Force Quitting' the Finder. When the Finder restarted after the force quit my drive showed up in the devices sidebar again.

To force quit hold down Option + Command + Escape, a dialog box will pop up showing you a list of all the applications that you're currently running, select 'Finder' from the list of open applications.

  • Not the politest way to restart the Finder. Also, wouldn't have fixed the OP, as he had deleted the sidebar icon, nothing more. – Tetsujin Jan 9 '16 at 12:47

I ran disk utility and ran first aid on my main ssd disk and the sd card popped back into existence.

Might have just gotten lucky but I tried everything else here and it didn't work.

  • Yes! This worked for me. Took a weirdly long time to load my disks into Disk Utility for some reason, but this did the trick. Thanks. – Bangkokian Sep 13 '17 at 4:49

It is odd that just removing and re-inserting the card did not allow you to access the card again. A reboot might help. Failing that open disk utility and see if the inserted card is recognized there. If so you should be able to select the device and format, partition or mount it from within Disk Utility.

If it is not showing up even in disk utility then there may be an issue with the card itself (or less likely) an issue with the card slot. If you have another you can try, do that. If not you may have to return the card for warranty replacement.

Ran into this problem today, but the answers weren't entirely clear.

By the OP's description, he dragged the SD card icon off the Sidebar in the Finder (in the older OS, this was animated with a puff of smoke and occurred with the Dock also). This removes from the Sidebar the shortcut to access SD Cards when they're inserted.

It can be activated again through Finder > Preferences > Sidebar and checking the box next to External Disks (you may notice that the box has a minus in it, indicating the removal of the SD card shortcut).

Either way, the card can still be accessed via it's icon on the Desktop if your Finder preferences are set to do so (General tab).

This happened to me today. It might not be showing up because as quip says since you dragged it out now you have to check it off on devices so it definitely shows up.

Also, since you pulled it out without having 'ejected it' you have to restart your computer as well.

My problem ended up being those and an SD card reader that sometimes had power and sometimes didn't so I had to repeatedly do that stuff till I got the files I needed.

how i solve this issue was, 1st use the search on the upper right of your screen (search for sd card) 2nd under the folders, you will see the sd card. 3rd open the go on the finder, open all documents 4th drag and drop the sd card from the search to the device in the all document windows.

that should let you see the sd card every time you insert it to your system.

  • How do your search for sd card? – Mark Oct 4 '15 at 13:57

Nothing works. That's the solution. Plug in the camera with a cable, that will work.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 5 '16 at 0:18
  • -1 This doesn't answer the question, which is about an SD memory card and not a camera. (The question doesn't state the SD card was used with a digital camera and there are many non-camera uses for such cards.) – Calrion Sep 29 '16 at 3:16

protected by Community Apr 23 at 18:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.