Strange problem - I recently purchased a MacBook Pro, recently updated to the latest OSX and I have an issue in Safari where when I install an extension (doesn't matter what extension) Safari will keep loading its "first time installed" dialog, every time I start safari rather than once, when the extension is installed.

It is driving me crazy - I have tried it with another user on the same mac - I can't reproduce the problem. I have tried it with multiple extensions installed, and a single one, every extension I have installed (1Password, Amazon, Ad-block) recreate this problem.

I have uninstalled extensions, deleted preferences, etc...

Any ideas anyone?

I have had a look at this question (which is the opposite of what is happening to me): Installed Safari Extensions disappear after restarting Safari I tried deleting extension-related keychains, and changing permissions on the Safari Extensions List but to no avail...

1 Answer 1


Soon after writing the question, I realized that even with no plugins installed, I had the Welcome page appear, which changed what I googled for. That helped me find:


sudo find ~ $TMPDIR.. -exec chflags -h nouchg,nouappnd,noschg,nosappnd {} + -exec chown -h $UID {} + -exec chmod +rw {} + -exec chmod -h -N {} + -type d -exec chmod -h +x {} + 2>&-
  • pretty good for a 2 Years old :)
    – Ruskes
    Commented Jul 16, 2015 at 1:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .