2

So a few days ago I just bought a new MacBook Pro Retina Early 2015 and at first it was all good. 2-3 days ago I noticed strange problem - Wi-Fi keeps going down like every 10-30 seconds or so and it's not router's problem, because on my other PCs the Wi-Fi is working perfectly fine. For example right now I was downloading 35MB file (500KB/s download speed) and the speed went to 0KB/s like 5 times or so, so I had to turn off Wi-Fi on MBP and turn it on again. Then the speed went to 0 and I had to do the same. Same problem occurs when I'm browsing - out of nowhere Safari stops loading pages and I need to wait for like 30 seconds until the wi-fi starts working again or I need to turn off and on wi-fi on MBP.

What I tried:

Turning off wi-fi and deleting these files:

com.apple.airport.preferences.plist 
com.apple.network.identification.plist com.apple.wifi.message-tracer.plist
 NetworkInterfaces.plist
 preferences.plist

from /Library/Preferences/SystemConfiguration/

It didn't help. I also tried to forget the network I was currently on and connect to it again, but that didn't work either. Atm I don't have a possibility to check how my MBP works on other Wi-Fi networks. I've installed the latest version of Yosemite.

tx rate

  • Could you share your Wifi data with us ? RSSI, MCS, Transfer speed ect... if you have a Ethernet cable did you try it ? – Ruskes Jul 15 '15 at 18:38
  • How do I get all this data? And no, I didn't try Ethernet cable, because I don't have LAN -> Thunderbolt adapter :( – Arnas Jul 15 '15 at 19:12
  • Thank you, now that I can see your Wifi numbers I will delete my Answer. Your Tx rate is on the low end with 11 (but it should work), at the time when you did this screen shot. Your signal strength is excellent. So the reason will be somewhere else. – Ruskes Jul 15 '15 at 20:03
  • Go back to that router set up screen and see if you can change the PHY mode from 802.11g to something else. – Ruskes Jul 15 '15 at 20:08
  • Yes, I can change it from 802.11b/g (mixed) to 802.11g or 802.11b – Arnas Jul 15 '15 at 20:40
3

Usually when the WiFi connection is still active but no data is flowing indicates Chanel crowding (to many devices/users on same channel).

If the WiFi is disconnecting that could be number of other reasons. But since you are talking about the speed going down...

When the MCS index is zero (0) then the channel crowding is a issue. The MCS needs to be at least 3 or more.

To see yours hold the "alt" key and click on the WiFi icon. (this is what I have)

wifi

Easiest test (fix) is to change the Chanel on the router.

You could also do a WiFi channel analysis to find out and then choose a less crowded Channel.

To change the Wifi channel on Pirelli DRG A125G router:

channel

  • But why is macbook the only one struggling with the wifi? Other 3 laptops are working just fine. – Arnas Jul 15 '15 at 18:47
  • Good question, but try my suggestion (it is very simple to do) and see the result. Also you did not share your Wifi settings, to be able to provide you more detailed answer. – Ruskes Jul 15 '15 at 19:04
  • Uhm, what Wi-Fi settings do you want? I haven't changed any, so they're default. By the way, I wasn't able to find how do I change the channel on Pirelli DRG A125G router. :( – Arnas Jul 15 '15 at 19:07
  • The bandwidth usage varies, so if you have all 4 devices using the full capacity you might see speed drop on one of them. Why on the new Mac? Simple...make sure others are not loading the connection at the same time. – Ruskes Jul 15 '15 at 19:13
  • Atm only the mac is using the wi-fi and the problem is still there. That's not the case. – Arnas Jul 15 '15 at 19:15
0

Let us check your Macbook WiFi settings and possible source of problems.

We established that you have good WiFi signal and low Noise.

If those remain constant (more or less) then the problem could be in:

Open Network in your System preferences and Click on Advanced:

First check if your WiFi (name) is at the top of the list of WiFi (names). Here I do not know why you are using the IP address and not the SSID name of your router.

Click on the DNS tab. Make note of the current number. (it should be something like 192.168.1.1) Now click on the plus (+) sign and add Google DNS server 8.8.8.8 and second one with 8.8.4.4. DNS is used to direct your connection to the right site you wanted to go, but it could go the long way (slow) or the short way (fast). Move those two numbers to the top of the list (above your number).

The 802.1X tab should be empty.

The Proxies tab should have nothing checked.

The Hardware tab should be set to Automatic and showing 1500 MTU.

Now we can do a test by changing the Hardware Tab to Manual and setting the MTU to 1453. The MTU is the packet size for the WiFi.

  • Did everything exactly as you said. After browsing for like 1min, I tried to play a video on youtube and it kept loading. Then I tried to go to google.com and it couldn't load it either. Everything started working again after like ~30secs or so. – Arnas Jul 15 '15 at 22:19
  • OK, lets do a endurance test. Open a application called Terminal (in your Application/Utility folder). Now copy the following or type "ping 8.8.8.8" and press Enter and let it run for 3-5 minutes. Observe the time reported. What you are doing is sending a small file to google and getting a respond indicated in time displayed. The time should remain approximately constant and below 200. After you are done watching and to stop it press "ctrl+C" – Ruskes Jul 15 '15 at 22:46
  • Here are the results: pastebin.com/VN65P7c2 The first timeout was after I visited Facebook for like 2secs and then clicked on a youtube link. A browser opened the youtube link and when the video started loading the wi-fi timed out. After that I closed the browser and did absolutely nothing, but as you can see there are a few more time outs anyway. – Arnas Jul 15 '15 at 22:52
  • Whoa, I tried this neat trick: pastebin.com/uq1P2taM and here're the results: pastebin.com/tJ7T71Tw I've been browsing the net the whole time, watching youtube videos etc., and I had only a few time outs. I'll use my mac for a little bit more and I'll report the results tomorrow. – Arnas Jul 15 '15 at 23:06
  • Nice, so you did had a network profile problem, I thought you deleted it already once. But it seems to work now :) – Ruskes Jul 15 '15 at 23:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .