I have a MacBook Pro Retina 2.5 GHz Core i7 with OS X 10.9.5 from March 2014.

I teach in an Adobe classroom every week, and have never had the following problem until last night after I downloaded the new Adobe Plug-in.

The video pod in the room has always recognized the camera on one of my two Thunderbolt displays as the video source (and optional audio feed) for my classroom. As of last night however, after the update downloaded in Firefox the Thunderbolt camera and audio are no longer recognized, only FaceTime HD is listed. I can get a video feed only when I open up the laptop.

The audio option from my displays is also gone from the list in Adobe. In Google Chrome, the Adobe room video dropdown option box essentially says, "No camera available" - so in Chrome it does not even recognize the MacBook Pro's camera as available. I usually use Firefox, and have never had problems until last night's update.

Bottom line, my MacBook Pro no longer seems to recognize that the Thunderbolt displays have a camera and audio feed available. Can someone help me to fix this please?

  • 1
    Have you tried using QuickTime to verify that the cameras are available in other applications where you are not using this special Adobe plugin? Jul 15, 2015 at 17:02

3 Answers 3



Open Terminal and type:

sudo killall VDCAssistant

Camera works now!


This might be the reason.

Mozilla blocks Flash in Firefox browser as Adobe issues emergency patch for latest security exploits as of July 14, 2015 / 8:15 am

While the block doesn’t completely prevent Firefox users from using Flash, it does mean users will have to actively click-to-enable the plugin.

  • I don't use Firefox, and I have this same problem on Skype and Zoom. Nov 17, 2018 at 12:59

I had the same issue with Macbook Pro (late 2020) running Catalina.

I installed this Driver: https://www.displaylink.com/downloads/file?id=1636

Then I checked the Allowed box in the camera screentime settings in Mac preferences to make sure the camera was enabled to always allow. It wasn't selected so this could have been the standalone fix without the driver.

Either way, the external display works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .