I read that on previous versions of OS X it was possible via hwprefs but I didn't figure out how to use it on 10.10.* (looks like it was removed). I need to disable HyperThreading for Wineskin.

  • 1
    May I know why you need to disable it ? (or why Wineskin needs to disable it). Also which mac do you have ? – Matthieu Riegler Jul 15 '15 at 13:38
  • 1
    Some programs don't work properly with HyperThreading link. Wineskin has a one check box in settings: "Limit to 1 CPU core (set at an OS level for all apps. Only work if you have hwprefs installed)" I have MacBook Pro (Retina, 13, Late 2012) Core i5, Intel HD 4000 – lebed2045 Jul 15 '15 at 18:08
up vote 18 down vote accepted

Indeed there is a solution, but you have to have Xcode installed.

Search for "Instruments" with Spotlight (cmd+space), open the application and go to the preferences (cmd+,). Select the "CPUs" tab and untick "Hardware Multi-Threading".

However, after restarting your Mac it will be enabled again.

  • Not only after restart but sleep as well. – poige Nov 7 at 19:10

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.