I have an iPhone 3G 16GB with iOS 4.0.2 and my wifi is not working, I tried to fix it with reset network settings and other quick fixes like that but it still doesn't work. Sometimes it sees wifi networks but I can't connect. I don't think is a hardware problem because I can see the wifi MAC address on the device.

Version: 4.0.2 (8A400) (jailbreak with redsnow)
Modem Firmware: 05.13.04

PS: On 3.1.2 the same thing. (jailbreak with blackrain)

Downgraded at 3.1.2, again...still nothing (jailbreak with redsnow)

  • Have you ever been able to connect to a WLAN at all? Or did you never succeed? – Martin Aug 16 '10 at 9:12
  • And what are the specs on the WiFi network you want to connect to? (i.e security) – Thomas Aug 16 '10 at 14:31
  • Yes, I`ve been able to connect before but now it can't find any network (not from home or office, sometimes it does but it says something like "unable to connect") I had 3.1.2 before, 2 hours ago 4.0.2 now I have 3.1.2 again jailbreak with redsnow same thing. I can see the wifi mac address so I guess is not a hardware problem (once again sometimes sees the networks but it can't connect) @Thomas is not the security, I disabled it nothing, with WPA nothing, router reset, iphone network reset still nothing... – Vlad Patrascu Aug 16 '10 at 17:35
  • Was the iPhone already jailbroken when you successfully connected to your router? – Martin Aug 17 '10 at 10:49
  • Yes it was, with blackrain and after 5 days or so, dead. – Vlad Patrascu Aug 17 '10 at 11:28

It may still be a hardware issue -- I had a similar problem last year. But since you say that your phone sometimes does see a wifi network, there's hope that the hardware is okay.

First, follow the comments posted here to make sure you're running a completely normal OS without any hacks or modifications.

Then, here's Apple's description of how to reset the network settings.

Lastly, if it still won't work, check my link above.

  • Resent wont work. I already did a network reset, then a full reset same thing... – Vlad Patrascu Aug 17 '10 at 16:56

It seems that many users of 3G experienced the same problem with WIFI when uphgraded to iOS 4

Perhaps some of the solutions listed here would help. In you case you are probably left with the the last option

Restore, but not from a backup. One less-than-ideal fix for this issue involves restoring the iPhone as a new device rather than from a backup. It appears that bad holdover data from iPhone backups can cause loss of data access. Restoring as a new phone will delete contacts and other data, but generally resolves this problem.

To do so, connect your iPhone or iPod touch to your computer, click “Restore” in iTunes, then choose “setup as new phone.”

  • I already did that, nothing. I downgraded from 4.0.2 to 3.1.2 same thing. – Vlad Patrascu Aug 17 '10 at 16:53

Try a stock (un-jailbroken) ipsw file from scratch. Use this procedure to downgrade properly.

I think that when you restore using your jailbroken image, you're just putting the problem back onto to the device. I've noticed that even after a brick, when I restore with redsn0w, it's not a clean install, as my previous applications and settings are still there. I think a fresh install of stock firmware may help. Jailbreak it only after you find out if original firmware works.

  • I restored with original (stock). – Vlad Patrascu Aug 17 '10 at 16:55
  • Hmm.....I'll keep researching and let you know if I find anything new – Thomas Aug 17 '10 at 19:32
  • Yesterday when I tried again to see if it finds any network, it did (my home wifi) but guess what my internet did not work lol, but the device successfully connected 3 times, when I tried the 4th time it did not work anymore... This is some weird... – Vlad Patrascu Aug 19 '10 at 6:36
  • It seems there is something, something that you wont believe... Here's the solution: You need one ****ed up iphone, one refrigerator. Take the iphone put it in the refrigerator (a/c) leave it for 5 minutes, and wow...it works. And I'm not making any jokes. But there`s a problem, when the iphone get's some heat again...boom no wifi (again) So is a heating issue, if you guys know any permanent fixes to that let me know. (like making some small holes in the back of the device, i'm kidding now). – Vlad Patrascu Aug 19 '10 at 19:55
  • LOL! Man, take it to the Apple Store – Thomas Aug 20 '10 at 12:58

What worked for me is going to settings / General / reset / reset all settings

Good luck, mine jumped back to what it was like about a month ago then it worked fine from there!

You must log in to answer this question.