7

I have suddenly started getting prompts on my 2014 Mavericks MBP (10.9.5) every five minutes that bring up a page with HTML like the following:

<HTML><HEAD><TITLE>Success</TITLE></HEAD><BODY>Success</BODY></HTML>

At the bottom of this modal window is a url:

http://www.apple.com/library/test/success.html

I am on my home network which uses an Airport Extreme running 7.6.4. I did not make any known configuration changes to either my computer or my network. Why am I suddenly seeing this page, which other posts suggest is a captive portal test?

I saw another question that demonstrated how to disable the Captive Network Assistant, but as I do take my computer to hotels that use these portals, I'm reluctant to jump straight to that. Instead, is there something on my Airport that is generating/blocking these all of a sudden and it shouldn't be? I tried a factory reset of the Airport and I'm still seeing this issue.

How can I configure my network so I stop getting these annoying popups?

  • 1
    Seems like the only common denominator is Mac OS 10.9.5 - only users in our office with 10.9.5 see it, haven't updated any other software. – Erwin Wessels Jul 15 '15 at 8:07
  • 1
    I noticed this just now too. I think apple broke something, that URL is returning the HTML as entity encoded ie "&lt;HTML&gt;&lt;HEAD&gt;&lt;TITLE&gt;Success&lt;/TITLE&gt;&lt;/HEAD&gt;&lt;BODY&gt;Success&lt;/BODY&gt;&lt;/HTML&gt;" This is broken on my friends' iPhone 4 running iOS 6.something, I got around the problem by turning off "auto-login" – Joel Pearson Jul 15 '15 at 9:38
  • I have raised a bug with apple (I have a developer account), with bug number: 21832176. Hopefully they fix it soon. – Joel Pearson Jul 15 '15 at 9:55
  • I have the same issue: OS X 10.9.5 . No update was installed by me. – sobolevn Jul 15 '15 at 10:45
2

The page has now been corrected, which should mean that the popup no longer occurs.

  • So there was an error on the test page that was causing this? – Troyen Jul 15 '15 at 18:30
  • Amazingly enough, that's my conclusion. Have to say, this seems like a rather unstable implementation, but hey, what do I know... I'm only a web dev! – Erwin Wessels Jul 16 '15 at 3:10
  • 1
    Yes, there was an error on the apple page, I finally got a response from Apple Developer Relations and they told me "Can you please verify and see if this issue still happening? We have changed something server side.". Obviously they fixed it a long time ago now. – Joel Pearson Aug 8 '15 at 1:18

You must log in to answer this question.

protected by Community Jul 15 '15 at 6:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .