4

I'm having trouble connecting 2 iPhones 6 and one iPhone 5 to a TP-Link TD-W8901N wireless router.

When I click on the Join button on the iPhone it tries to join (upper side of pic) and then it stops (down). It's like a circle and repeats over and over....

I am able to join via Wifi with my laptop.

I can connect to another router with my iPhone.....

I did restart router several times.

Router settings:

  • Channel: 1, 6, 11, auto (have been tried)
  • Wireless Mode: 802.11 b+g+n
  • Channel bandwidth: 20/40 MHz
  • Authentication Type: WPA-PSK/WPA2-PSK
  • Encryption: TKIP/AES
  • Transmit Power: High
  • Beacon Interval (ms): 100
  • RTS/CTS Threshold: 2347
  • Fragmentation Threshold (bytes): 2346
  • DTIM (ms):1

enter image description here

  • 1
    did you try without authentication? open network ? – Ruskes Jul 14 '15 at 16:55
  • What iPhone? Is there a 5GHz network also available? TP-Link model and firmware? Thanks – Jaime Santa Cruz Jul 15 '15 at 2:45
  • The router may be set to deny unknown MAC addresses. Check MAC address filtering section of the router setup. – Tyson Jul 15 '15 at 3:51
  • thank you guys for your answers @Buscar웃SD : I have tried but still doesn't work – Hossein Zahirnia Jul 15 '15 at 21:34
  • @JaimeSantaCruz : 2 Iphone6 and one Iphone5, TP-Link TD-W8901N, firmware:1.0.0 Build 140825 Rel.25346 – Hossein Zahirnia Jul 15 '15 at 21:34

10 Answers 10

6

I had the exact same issue with a tplink access point and this made me crazy. Nothing worked for me, until i found the solution:

Disable WMM in the wireless advanced settings!!!

  • I've tried a lot, specially when starting to see an youtube or vimeo or video of anykind, the wifi was going off. I've have one TL-WR740N and after disabling the WMM the connection haven't dropped, yet. – andrepazleal Oct 3 '18 at 0:19
0

Try modifying some parameters, one at a time, and see if you're able to connect:

  • As suggested, try different security settings on your wireless network: WEP, WPA, WPA2 (TKIP/AES); open (no wireless security).
    Don't forget to set up security back after troubleshooting.
  • Enable / disable WPS
  • Test different wireless modes: 802.11n only, g+n, g only
  • Updating your router firmware may solve any issue you encountered on the previous steps.
    In this particular case, I saw nothing on the updates that suggested problems with iPhones in particular, but security and other bugs are solved routinely, so it's a good idea anyway.

Be careful when selecting the firmware: many routers have more than one hardware version. Only update with the firmware that matches your version.

  • 1
    In addition to the excellent suggestions here, I would also try setting the router to narrow channels only, that means set channel bandwidth to 20mhz only instead of 20/40mhz – Tyson Jul 16 '15 at 4:12
0

I had the same problem (with 1 iPhone 6 and two iPhone 6s, IOS 9.1), but my router is a TP-LINK TL-WR1043ND. I disabled QSS and the problem was solved. By the way, my iPad 2 had no problem using the same wireless network (running IOS 9.1).

  • Thank you for your answer, please provide more details and steps in your answer. For example, how to disable QSS, etc. – Behdad Nov 21 '15 at 7:51
0

Same here ! I just moved my extender to another room and seems it's better, even though less signal but at least I can surf online from my IPhone 6.

0

I had the exact same issue with my WR1043ND and an iPhone 6s.

What solved the issue for me was:

Option 1: Change channel width to 20MHz.

Option 2: Change mode to either 11b only, 11g only, or 11n only. Do not choose a mixed mode.

Option 3: Use channel 11. I'm not sure about the science behind this, but for some reason I can set the wireless mode to 11bgn mixed, channel width to auto when I choose channel 11 (and my iphone with iOS 9.3 beta 5 won't disconnect).

Enable WMM was unchecked with these 3 options, but alone it didn't work.

0

I the same problem and got solved after unplugging and reseting everything connected to the router, it was an ip conflict between my iphone and a previously DHCP set domotic controller. It may sound silly, but forgot to check the ip addresses of every device.

0

I had similar problem with a resurrected iPhone 5 and TP-Link Archer C3200. Although I have quite a lot of other working devices - iPhone 4s, iPhone 6s, Sony Vaio, MacBook Pro, MacMini, Asus Chi T300, Chromebook, Sony Smart TV, Samsung smart TV, you name it...

The iPhone 5 will connect to WiFi with no problem, it just wont connect to any internet sites via Safari or any apps. After banging my head against this for many hours, including Googling and trying different suggestions such as those offered here to no effect, I finally noticed that my router is assigning an IP address to the iPhone via DHCP that is already given to another computer via DHCP! I wonder how this could even be possible? Bug in router firmware?

So to work around the issue, I use the router's web admin interface to lock down another IP address based on the phone's MAC address - and voila! The iPhone 5 can now surf the web with ease.

0

Thanks God After Changing high power to low power mode (19dbm) its working iphone uses 2.5ghz to connect to any phone while we use high power its move to 5ghz on high power so change the high power to low power in wireless basic setting thanks

0

Pulling my hair out over my old ipads not connecting to my new TP-Link Archer. What worked for me was to set the 2.5ghz to WEP security, even though my old Billion was WPA2 and the ipads had no issue before. Not ideal but it works.

-1

1) changed channel to 11 2) disabled QSS 3) disabled WMM PROFIT!!! Thank you all

You must log in to answer this question.

protected by Community Jan 29 '17 at 9:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .