2

I have been trying to update my iphone 4 from ios 7 to ios 7.1.2 for months but it has never worked. I go into software update in settings, I see that I can update my phone to 1.7.2 so I press download and install. Then comes terms and conditions so I press "I agree". Straight away it starts downloading but it is pretty slow. It keeps on downloading until it is halfway done with the process bar. Right beneath the bar were it stood estimated time remaining it says now "preparing update..." When that happens the update suddenly is super slow. It nearly doesn't go forward. After few minutes of waiting, the update stops and I recieve a message saying "Software update failed. An error occured downloading IOS 7.1.2." I have tried rebooting my phone but that didn't work. It's like something is preventing me from updating my phone but i don't know what it is Can please someone tell me what I am doing wrong

3

Have you tried doing it using iTunes after connecting the phone to a computer - Mac or a PC? That should work technically. You should be able to set the phone up as new if everything else fails.

Don't rely on the OTA, especially coz it's the old version of the OS you'll be getting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .