2

I am trying to install old software on my either one of my Macs (Powerbook G4 and iMac 21.5 from 2011).

This software contains old fonts in a very rare format, which I would like to be able to watch / install / convert (eventually). I have tried opening the font files in OS X with almost every font program available (FontBook, FontDoctor, FontForge, FontLab, Fontographer, TransType4...) and have come to believe that they can only be viewed on an older system for which they were designed.

I opened another discussion about how one might open these rare / old file formats on today's machines but it doesn't seem to be possible.

So, the software I am trying to install is on three different CD-ROMS hat are designed for Mac OS 6/7/8.

I have two partitions on the Powerbook, one with OS X 10.3 that can run Classic (Mac OS 9.2), and one with OS X 10.5.3 (most recent possible system for this machine), this way I can go back and forth systems.

When I try to launch the installer CD in the Classic environment, the top menu bar becomes grey and Classic freezes, so I think this CD can only run on machines earlier than 9.2 / 9.0, such as 7 or 8.

On the iMac, I have SheepShaver with OS 9, Basilisk with OS 7 and Mini vMac. None of these recognise the CD ("disk is unreadable). If I create a .DMG copy of the CD, or a copy of the files, I can open and run the Installer successfully in the beginning (with Sheepshaver / System 9 and Basilisk II / System 7), but after a few registration steps, the installer program asks me to insert the CD and fails to recognise it. (I tried starting these emulators when the CD was already in the drive, no chance.)

enter image description here

I believe I could go and buy one of these old clamshell Apple laptop that runs 8.2 but I'd like to do without. I also considered installing 8.0 with original install CDs into SheepShaver, but people online say Sheepshaver / Basilisk are usually touchy when it comes to recognise CD-ROMs.

EDIT: Here's what fontographer does:

fontographer cannot open TTY

EDIT (2): I found out how to solve this problem. Here's how: I created three read/write disk images, one for each install CD, using Disk Utility in OS X. Then using BasiliskII, I added each .dmg file to my preferences window.

Upon restart, all three CDS showed up and could be used without the CD.

(In my previous efforts, I had not tried to convert each CD into a .DMG file or didn't know how to add them as drives into Basilisk.)

Thanks for the help! Can someone please mark it as "solved" if you have clearance.

3
  • Did you try Fontographer? Definitely does afm & tty – Tetsujin Jul 14 '15 at 7:18
  • I've edited my answer to answer your question about Fontographer ;) – MicroMachine Jul 14 '15 at 22:32
  • Wrong way round - make the last edit an answer and then you can mark it s solved. , no one else can – mmmmmm Jan 9 '17 at 19:08
3

You need to use a CD/DVD Authoring software like Toast to mount the image inside the emulated classic Mac (SheepShaver). The CD mounter that is built in is not good enough to trick software that looks for the original disk. Software like Toast Mounter can though.

2
  • 1
    BTW, the fonts on the screenshot look like old PC version Postscript fonts (afm = adobe font metrics), and the .tty ones could be old PC-truetype fonts, try renaming them with their modern extensions .ttf, not really sure. OLD MAC fonts store their postscript in the resource fork and should be converted to .OTF for modern MacOS or they could loose that data in the transfer process. – DaMacGuruKing Jan 9 '17 at 19:11
  • A popular alternative to installing a full classic Mac authoring package just to mount disk images is a little utility for mounting disk images such as the public domain Virtual CD/DVD-ROM Utility – rakslice Jun 17 '20 at 23:31
2

From your question, are you implying that OSX has no problem opening and reading the CD-ROM but then doesn't recognize the format of the font files?

The question I would have is what format is the CD-ROM? Is it ISO-9660 or some other format that perhaps needed a special driver back in the Mac OS days? I can't say I'm necessarily aware of the variations, but I struggle to think of why it wouldn't be recognized by the emulators if it was a standard format with appropriate drivers.

That all being said, if the problem is that you want to use the font files on the CD-ROM and OSX recognizes them, why not copy them to your OSX machine and then burn them to another CD? Better yet, I think you can access an OSX directory from Basilisk so why not just copy the files there?

4
  • I have been led to assume that the "installing software" which runs on OS 7/8 does something to the font files to make them usable / installable. At least, if I could run the software, I would see what it does to install them on a OS 7 system. Maybe the installer program just copies files to the font folder, maybe it converts them. If it copies them to the fonts folder, then maybe from OS 7/8 I can batch convert them. But as for now, the CD-ROM, while designed for OS 7/8 machines, cannot be read by emulators. I copied the CD into a DMG and the Install program still asks to be "fed" the CD. – MicroMachine Jul 14 '15 at 22:35
  • @fabriced, have you tried just copying the entire contents of the CD-ROM to a "standard CD-ROM" DMG? From what I remember, the Apple-specific forks of the filesystem were always visible as regular files/directories on a CD-ROM, so you should be able to copy cleanly. If not, can you mount the CD-ROM in OSX and make it visible to the emulator as a shared folder? I suppose the only problem would be if the CD-ROM has some kind of copy protection scheme that neither OSX or the emulators recognize. – bjb Jul 15 '15 at 12:11
  • I mounted the CD in OS X and created an alias into the shared folder. When I double-clicked the alias it said "please insert the disk: browser CD" (the disc is in). What do you call a "standard CD-ROM DMG"? Are you suggesting something different than what I explain in the original question (§ above b & w capture)? – MicroMachine Jul 15 '15 at 16:36
  • By standard, I meant straight-up ISO 9660. I think in the MacOS-era, you could have a HFS CD-ROM or a hybrid of both HFS and ISO 9660. Not sure what your disc is, but perhaps it is ISO 9660 and you don't have the correct drivers installed; check tempel.org/joliet and see if that helps the emulator see the CD? – bjb Jul 15 '15 at 20:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .