I use AirDrop quite often to quickly send pictures that I take on my iPhone, to my Mac. The problem is, I have several Macs (all of them are Mac minis) and when I activate AirDrop on my iPhone, they all show up with the exact same name.

AirDrop on my iPhone

I've Googled, and the only three ways of changing the displayed name in AirDrop that I've found are:

  1. changing the computer name in System Preferences -> Sharing -> Computer Name,
  2. changing the "Me" card's name in Contacts, or
  3. modifying a Plist file with the command
    defaults write com.apple.NetworkBrowser DisableAirDrop -bool YES.

Unfortunately, none of these are working for me. 1 doesn't seem to apply, as my computers already have unique names in the Sharing control panel, but they don't show up in the AirDrop display on my iPhone. 2 wouldn't work, because changing the "me" card would sync across to the other Mac (my contacts are syncing using iCloud). I tried 3 and it doesn't work either - the AirDrop item disappears from Finder, however my computer still shows up in the AirDrop display on my iPhone. The only working solution I found was by turning off WiFi on any computers that I don't want to show up in AirDrop, which prevents them from showing up in AirDrop on my iPhone. Fortunately this works for me, since I typically AirDrop files to only one of my computers, and all of my computers are connected via Ethernet anyway, so WiFi is unnecessary for network connectivity. Is there a different way of either changing a computer's name or making it disappear entirely from AirDrop?

  • 2
    Have you tried editing the name in System Preferences > Sharing ? Jul 13, 2015 at 23:35
  • Same problem. I changed my name in iCloud Preferences > Account Details, which is the only place I can find my full name instead of my nickname that I want. Still hasn't affected AirDrop, but I think that's maybe the answer in the long run.
    – AbePralle
    Oct 22, 2018 at 2:03
  • 1
    There doesn't appear to be a way to alter this behavior (when signed in to iCloud, AirDrop uses iCloud data, rather than getting names from the devices). Best thing would be to send Apple feedback for MacOS or iOS.
    – outis
    Nov 26, 2021 at 22:13
  • This is hardly a solution, but I typically find the most recently used device appears first in the list
    – duozmo
    Jun 4, 2023 at 19:05

4 Answers 4


You can opt out of AirDrop on a Mac quite easily.

  • turn off WiFi
  • Use an OS X Profile to disable sharing via AirDrop (MDM such as OS X server.app's profile manager can do this easily)

Setting the name should be easy to test. Open the sharing preference pane and make one Apple an Orange. Watch that the names change. If not, you've got a caching issue with your network and might want to power off all AppleTV and Airport devices at the same time to get a clean start to that cache. I haven't figured a more elegant way to purge the collective shared cache of bonjour names that works as well as a total outage there.

  • It's not showing the computer name at all. It shows the Apple ID user's name and the top of device.
    – samh
    Aug 4, 2016 at 23:45

For me just now using ios 10.3.2 and macos Sierra, changing the computer name in System Preferences -> Sharing worked great. You said that didn't work for you, but it may help others.


One clue is that the Current User in Users and Groups menu is associated with one of your contacts. I've tried to modify the first name of my contact card. On my iPhone, it did display with modified name.


You might try to create different contact cards for your computers to distinguish them (even with different avatars). I haven't tested it, 'cause I have only one Mac.

Hope it's helpful.


Open Disk Utility and then in the left-hand column highlight the drive/name you want to change and then boink (double-click) on the name that comes up large in the middle and you can change it there.

  • That renames the startup disk (the name of the volume used to boot the Mac), not the name of the Mac itself. (You can always comment on and edit your own posts. I've deleted the other post and edited this to be a standalone answer.)
    – grg
    Oct 31, 2017 at 20:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .