I'm running Mavericks 10.9.5.
This is my java version:


Whenever I started Minecraft up, it would immediately crash.

I tried:

  • Reinstalling Minecraft
  • Deleting the minecraft folder in Application Support
  • Reinstalling Java

Hints for the problem:

  • Downloaded the most recent Java. Version 8 Update 45.
  • Ran this command in terminal:

sudo mv /usr/bin/java /usr/bin/java-1.6
  • Ran this command in terminal:

sudo ln -s '/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Content­s/Home/bin/java' /usr/bin/java

I was having troubles with running a plugin, so I thought it was my java. After I did all of that, java wouldn't work at all. I tried to enter "java -version" in terminal, and it would say "unknown command".

After that happened, I went to Apple Java, and installed the most recent build, found here: https://support.apple.com/downloads/java

I installed "Java for OS X 2015-001 Beta.

After that, I could type in "java -version" with no problem. After I restarted my computer, Minecraft wouldn't launch. When I try to run my own server, it starts up, and then it fails and crashes.

Note: Java Control Panel also crashes on launch.


3 Answers 3


Do you have mods? Delete those first then try. To delete them go into application support then minecraft then mods and delete them.


I think your java version is not supported by minecraft version.

try upgrading jdk


Have you tried to Delete Minecraft on your computer and reinstalling it? (Not sure if you need to buy it again)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .