0

My (12-inch retina) MacBook periodically joins a wrong wifi network, ignoring the preferred networks list in network preferences. (I'm using the latest version of Yosemite)

The wifi network is a 'special' network, it's my ISP's hotspot. After connecting to the network I am shown a pop-up asking to log in using my ISP login credentials. This is quite annoying.

I keep manually deleting the network from the list. But when I'm on the go, I often have to join the hotspot. I would simply like my MacBook to ignore the network whenever I'm at home.

Things I have tried so far:

  1. Moving the 'bad' network to the bottom of the preferred networks list
  2. Moving the 'bad' network to the top of the list (you never know, right? Haha)
  3. Deleting all keychain entries related to the hotspot (it ignores those, I always have to re-enter the credentials in the pop-up window anyway)

Is there a solution to this problem? Or should I write a simple Apple or bash script which periodically deletes the hotspot from the known networks list?


Edit:

As requested by user unknowndomain below, here is some additional info.

At home I never want my computer to connect to the hotspot, only when on the road. (they are spread around the country). My home network is always on. It happens in other people's houses as well, my MacBook seems at certain times to prefer the hotspot ignoring other known ('higher priority') networks. I have the same problem with my old MacBook and with my girlfriend's MacBook Air so it's definitely a software related problem.

Some details of my home network 'Den Draad' and the hotspot 'TELENETHOMESPOT'.

Home network details enter image description here

  • It's a little strange that after moving it to the top of the list that it is still not respecting your preference. Do both networks have the same name or something? Could you provide a little more detail on the setup of whats happening? – unknowndomain Jul 12 '15 at 21:58
  • Added some network details of my home network and the hotspot. They definitely don't have the same name. – Kymer Jul 12 '15 at 22:17
  • I see, so your seeing the latter when you are away and at Home, thats why it is happening. Does the Den Draad network turn on and off? If you loose connection it will connect to the other one then it won't reconnect to yours unless you set it to. – unknowndomain Jul 12 '15 at 22:20
  • Bit confusing to me. So you do connect to that network when on the road, but do not want to connect to it when at a home ? – Ruskes Jul 12 '15 at 22:26
  • 1
    Ok, you have the TeleNethomespot router/modem. That broadcasts two WiFi signals. One is private the other is public. See some instructions here telenethomespot.be/portal/settings/en/index.html and more here telenethomespot.be/portal/info/en/index.html. Since you stay signed in in Telenet your Wifi will randomly choose which one to connect to once at home (close to your router) since both signals have same strength. The only option you have is to disable the keep me signed in on the start up screen, which will result in you having to sign in when on the road. – Ruskes Jul 12 '15 at 22:40

You must log in to answer this question.

Browse other questions tagged .