I can't open the App Store, and I can't open software update. I've tried all the troubleshooting advice I can find online, but none of it solved my problem, so I figured an OS update was overdue. I'm hoping that will fix it.

I can't seem to update without the app store, though!
I ran sudo softwareupdate --install —all and restarted (sudo shutdown -r now), but "About this Mac" still tells me I'm on 10.9.5. (Again, clicking the "Software Update" button tries to launch software update, but fails.)
Now, when I run sudo softwareupdate —list it says, "No new software available."

Is there anything else I can try before I have to take it to the Mac store?

  • 1
    Also - you can't install a new OS from the command line. You have to get it from a working App Store app. If your Mac isn't cooperating, find another Mac to sign in to the app store and download the installer there. Once you have the installer, USB drive it to the sadder Mac... – bmike Jul 11 '15 at 14:24
up vote 5 down vote accepted

Get someone to download the installer from the App Store - just download it, don't install.

Apple documents how to create a bootable installer - https://support.apple.com/en-us/HT201372 using any USB drive or even an SD card should your Mac have that slot.

  • Plug that device in to your Mac.
  • Remember to hold down the option key when your Mac starts up.
  • Select the device.

One last thing, make sure you check your backup before installing. Time Machine is best. The upgrade isn't designed to have problems, but you never know.

I'd really consider trying to fix the existing OS long before exacerbating the situation by trying to force another over it.

  1. Start with Disk Utility - Repair Disk Permissions & Verify Disk [startup from the Recovery partition, Cmd ⌘ R at the startup chime, if the Disk needs Repairing].

  2. Again from the recovery partition, reset home folder permissions & ACLs, as per this answer - https://apple.stackexchange.com/a/163449/85275

    • Steps 1 & 2 can instead be performed using the freeware Onyx utility…

enter image description here

  1. Run the latest combo updater for 10.9.5 - https://support.apple.com/kb/DL1760

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.