1

Only since yesterday, I am unable to find an access point on my macbook pro (MBP) running Mavericks 10.9.5. Interestingly, all my other devices (Nexus 5, Ipad, Macbook Air) can see it and connect to it. All devices are in line of sight to the router. The router is broadcasting the SSID. Also the MBP connects to my other access points just fine.

I have tried the following:

  • Restart the router. Twice.
  • Turn wifi on and off on the MBP
  • Connect to the wifi network using 'Join Other Network'. This results in 'No network found.'
  • Restarted the MBP
  • PRAM reset on the MBP
  • SMC reset on the MBP
  • Change the wifi channel on the router
  • Renamed the SSID

I am really stumped and need help to figure this out. Thanks.

EDIT: The wifi access point became visible again. No changes were made to either mac or router. Neither were even rebooted. I took my mac to work and connected it to the office network. When I returned home, the rogue wifi access point was connectable.

I am closing the question by selecting the first answer since I learnt something new from it.

  • did you try to manually connect ? – Ruskes Jul 11 '15 at 2:45
  • Thanks for your comment. What do you mean by 'manually connect'? I did try to use the 'Join other network' option. – Shoan Jul 11 '15 at 4:21
1

You can try to manually connect using the terminal (copy and paste following (one by one).

You can skip step one and two, and go to step 3, and enter your SSID and password.

Turn On

networksetup -setairportpower en0 on

Find

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Connect

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

In your case it sounds like your Router is denying you the access. The settings depend on the router type.

Here is a example of mine. (not blocking anyone)

MAC blocking

You know this but just making sure:

ap

  • Thanks. I get this error Could not find network xxxxx. – Shoan Jul 11 '15 at 4:33
  • then try using the Find command – Ruskes Jul 11 '15 at 4:37
  • Tried the find. I don't the see the AP listed. I got 2 routers. I see the second one, but not the first. – Shoan Jul 11 '15 at 4:57
  • Is it a hidden SSID ? – Ruskes Jul 11 '15 at 5:15
  • No. It is visible and broadcasting. Also tried renaming the SSID. That didn't work either. The weird thing is that everything was fine 24 hours ago. Nothing changed on the mac (no software updates) nor on the router. – Shoan Jul 11 '15 at 5:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .