46

I've tried everything I can think of. Resetting the router, changing the channel number and band.

The internet connection is fine, and then just hangs for a minute or 2, then returns to normal.

The wifi icon remains connected, and I have the latest 10.10.4 update installed. At first I thought it was a DNS bug with Yosemite, and have played with the settings such as changing DNS provider, changing the IPV6 to IPV4 only etc.

Driving me nuts. Has anyone had a similar problem? I've checked the surroundings with wifi scanners and have chosen the best channel available.

  1. One thing I have noticed, it seems a lot more reliable on 5GHz as opposed to 2.4Ghz
  2. It seems to affect my Macbook Pro Retina 13in Early 2015 a lot more than the other devices on the network.
  3. I'm using a Virginmedia Superhub 1.
  • 1
    See if you can persuade Virgin to give you a v2 hub; they're slightly better than the v1s. BTW, afaik, Virgin have no IPv6 capability at all yet. – Tetsujin Jul 10 '15 at 15:48
  • Just to clarify, you loose the WiFi but the modem/router is still connected ? looking at the lights on the router. – Ruskes Jul 10 '15 at 16:00
  • I have if not the same, so a very similar problem. I use a 1TB Time Capsule cabled to the ISP modem as wifi access point. – Thorbjørn Ravn Andersen Jan 17 '16 at 18:52
  • 1
    Same problem here, on 2015 MacBook Pro El Cap 10.11.3. The WiFi remains connected but heavy packet loss. Since it happens when connected to an iPhone via personal hotspot with working internet connection it is not a router issue. Timeouts when pinging the iPhone's local IP reveals the issue is at the 802.11 transport layer. – malhal Mar 4 '16 at 11:58
  • This helped for me: superuser.com/questions/972037/… – Yohan Liyanage Nov 27 '16 at 12:22
26

I was having a similiar issue with 10.10.3 which was not corrected when I updated to 10.10.4. Many, many things were tried before I got it to stay connected to WiFi reliably, however deleting the networking PLIST files seems to be what finally did it.

The Fix:

  • Disable WiFi
  • Open Finder
  • Press Cmd+Shft+G to go to the folder /Library/Preferences/SystemConfiguration/
  • Delete (or move) the following files:
    • com.apple.airport.preferences.plist
    • NetworkInterfaces.plist
    • preferences.plist
  • Restart your computer
  • Re-enable WiFi

The Other Things I Tried:

  • Reset PRAM
  • Reset SMC
  • Used Onyx to clear caches, run update scripts, etc.
  • Disabled AirDrop by using Terminal to run sudo ifconfig awdl0 down
  • Kext Utility to reset kext permissions, followed by...
  • Disk Utility to verify/correct permissions.
    • In my case errors were found, and I had to...
    • Reboot in Recovery Mode (press Cmd+R as boot sound, hold until you see the Apple logo), use Disk Utility, however no errors were detected
    • Disabled FileVault, waited for decryption to complete
    • Reboot in Recovery Mode, use Disk Utility, some errors corrected then return value 8 and was told I had to backup, format, and restore to the drive.
    • Ran Disk Utility repair again and no errors were detected (then I ran it again for good measure)
    • Rebooted and Disk Utility found no errors.
    • Still had WiFi disconnects...
  • Deleted the AirPort plist files (fix above) and WiFi has been stable.
  • Do you know why these three files were the one to delete? – Thorbjørn Ravn Andersen Jan 17 '16 at 19:03
  • 2
    Seems to have worked for me. Tight! – dsp_099 Feb 4 '16 at 2:33
  • 1
    Worked for me too, clearing out those preference files. I hope someone at Apple see this post ! – Dan J May 11 '16 at 21:55
  • 1
    Worked a treat for me too. It also really sped up my browser experience, thanks. – jjnevis May 12 '16 at 11:48
  • 1
    UDATE: Actually, the problem has started again, so only a temporary fix. – jjnevis May 13 '16 at 9:55
10

Wi-Fi dropping and losing Internet connection are two totally separate things.

If your Wi-Fi drops, you lose connectivity to everything on your network. If your Internet drops, you only lose connection to the outside world, your internal network is still good.

Below is a general picture of a home network with Intenet.

Home Network

(The cable modem used here can also be a DSL router, a fiber connection, or any other high speed connection, this explanation isn't limited to cable modems)

If the connection between the Cable Modem and the Internet dropped, you would still be able to communicate with all the other devices on the the network itself. For instance, you would still be able to print a document or stream music to your entertainment console from your iTunes library on your computer.

First, let's determine if it is your Wi-Fi or your Internet.

Get your IP address and the IP address of your router. Under Settings --> Network, you will see your IP and Router. (I am using Ethernet here, but it is exactly the same for Wi-Fi)

Network Settings

In this case, my router's IP is 192.168.10.1

Testing the Wi-Fi connection.

If your Wi-Fi drops, first it will appear disconnected (red or yellow dot) like mine is in the picture. You can also try and ping the router.

In Terminal, type the following command:

ping -c 5 <your router IP>
ping -c 5 192.168.10.1   <-------- Example using my IP

You should see results that look like (the top half) of the picture below. If it fails, it will look like the bottom half with the "Request timeout" error

enter image description here

If it's successful, then your network is working. If not, then there is a problem with either your Wi-Fi adapter or with your modem/router iteself

If it's working, trying pinging Google or one of the public DNS Servers. Enter the following in Terminal:

ping -c 5 www.google.com    <----- This should work, but if DNS is failing, try the next line
ping -c 5 4.4.4.4 <------ If you can't hit this, your connection to the internet is failing

If it fails now, then your Internet is not working and that will require a service call to your provider.

One other thing you can try is connecting an Ethernet cable directly to the router/modem and disabling your Wi-Fi. If you no longer have drops in service, we will know that you have an issue with Wi-Fi. It could still be either your computer or the router/modem, but we will know what is working and what is not.

How can we tell if it is a Wi-Fi issue with either the router/modem or with your iMac?

This is where another device comes in. If you have an iPhone or another computer or a tablet, check to see if you have connectivity when your computer's connection drops.

  • If you don't then it is the router/modem. Time for a service call with your service provider
  • If you do, then chances are it's your computer. More diagnostics and checking of settings, but time to setup up an appointment with Apple service.
9

I have been experiencing the same issue of wifi dropping in and out since upgrading to Yosemite on my MacBook Pro 13" with retina display (early 2014). Having read many discussions, the answer that solved this for me was to use the terminal command:

sudo ifconfig awdl0 down

By disabling AirDrop, which I never use the wifi connection on my Virgin Media SuperHub 2 appears to be stable. All other devices, iPhones, iPads etc were not affected by the issue, so I believe it is something in the code for Yosemite to do with how wifi is managed that causes this issue. I am hopeful that El Capitan will have a different / resolved bit of code for this.

  • Since AirDrop shares the WiFi interface it definitely sounds plausible it could be destroying the real WiFi connection. – malhal Mar 4 '16 at 12:17
  • And for me this worked like a charm! Thanks! Finally normal ping and speed! – imike Jul 7 '16 at 7:14
4

Ok I've got to the bottom of this. It was my router. I have now upgraded from a Virginmedia Superhub VMDG480 to the latest Superhub 2ac. Its been over a week now and the connection is solid, so I'm answering this myself.

Their latest kit has concurrent 2.4Ghz & 5Ghz, which I think has resulted in a more robust connection overall. Considering there where three phones, a media server, 3 computers, two tablets, a printer and an Xbox on at any one time, I just don't think the 2010 kit could hack it. Not to mention the extremely crowded 2.4Ghz band in my area.

I think the reason it seemed to affect my Macbook more than other devices is that, after testing against other devices, the wifi reception doesn't seem as sensitive as other devices, meaning, it dropped the connection a lot more than devices at the same range. As a side note, my Galaxy Tab 8.4 Pro seems to have super robust wifi reception in comparison with the Mac.

  • I do not think this is a problem with the Wifi-connection but with the routing tables. – Thorbjørn Ravn Andersen Feb 3 '16 at 21:33
  • Thanks for this suggestion. I've been having persistent dropouts and slowdowns on 5 GHz, not on 2.4 GHz. When I checked the connection status on my Mac, I could see that the 5 GHz signal had only 10-19 dB SNR and was running at very low speed (13-27 Mbps, MCS 0/1) whereas the 24 GHz signal was stronger and faster. Turns out that my router (BT Home Hub 4) has poor 5 GHz signal for some reason (this is through just one wall). I've been using separate SSIDs for A and B, but I think now I'll combine them and let clients choose 5 GHz automatically, only when the signal is stronger than 2.4 GHz. – qris Dec 23 '16 at 22:25
3

Ah, have this issue too. I must say though, when I purchased a new router and made the SuperHub in a modem, that's when it works the most. I still get the internet drop everyone and then. In fact, here is one proof. enter image description here

The terminal window above is pinging google and the one below is pinging the router I purchased and plugged to the SuperHub(now acting as a modem). While at the point of this screenshot, the internet was down. Other computer connected to the same router, the internet was on and they experienced no internet drop. Which is very odd. But that being said, getting the router and making the SuperHub did make me have the internet 4 out of 5 times, as opposed to 1 out of 5 times when connected directly to the SuperHub's wireless (2 or 5 GHz).

Here you'll see the internet suddenly decided to come back up, while responses from the router below was still consistent.

enter image description here

And this only happens on the MacBook Pro, no other system on the network (iMac). Still puzzle.

I am yet to try reseting SMC etc. But as a good solution, I would recommend getting a router and using the SuperHub 2 in modem mode - if you are still having problems i.e. --Basically, I made the SuperHub 2 work in modem mode (which switches of its routing function and makes it just a cable modem). And got another router to do the job providing the wireless signal needed

  • Ah OP, didn't realise you had a working solution already. Will leave the post anyway, incase others are having issues. I say this because your solution did not work in my case. – user54287 Sep 15 '15 at 10:13
  • It's a bit hard to find the answer in your post (and the screenshots don't really help either), can you try to describe your solution more specifically? – nohillside Sep 15 '15 at 11:45
  • Was explaining the problem I was having and the process that helped to alleviate it. Basically, I made the SuperHub 2 work in modem mode (which switches of its routing function and makes it a cable modem). And got another router to do the job providing the wireless signal needed. Hope this explains it better. – user54287 Sep 15 '15 at 11:50
  • Can you work that directly into the answer? Comments tend to get deleted sooner or later. – nohillside Sep 15 '15 at 11:50
  • 1
    Ah! Thought that was what I did in the last paragraph - in italics. But will do as suggested. – user54287 Sep 15 '15 at 11:51
1

The same thing happens to me! I don't know how to permanently solve this problem, however, but I find that turning Wifi off then on will solve the issue. This is only temporary though, because it always seems to drop the Wifi once every while.

  • 1
    Do you use a Logitech Mouse? – Chris J Allen Jul 15 '15 at 15:28
  • nope a wireless mobile microsoft mouse. I am however, using the same laptop. Macbook Pro 13 inch 2015 model Retina display – Jeremy Jul 15 '15 at 17:24
1

I have had the same problem. What seemed to work for me was deleting all the WiFi networks I had saved on my system in the 'Preferred Networks' list in settings, network, wifi, advanced. Then just re-joining the network i needed again.

0

I tried all the solutions here, and nothing fixed the WiFi dropping.

The solution that worked for me was buying the WiFi cable as I read in this post: http://warrantyvoidifremoved.blogspot.com/2014/01/repairing-intermittent-wifiwireless-on.html

I was quite sure the problem was the cable because I tried a workaround to "protect" the cable. I put two coins in both sides of the cable to avoid that cable enter in contact with the button cover of the macbook... And the WiFi stopped working completely after a few attempts. That's how I was quite sure the cable was not OK. I toke a photo of the macbook and coins to remember!

attempt to fix the WiFi cable problems with two coins around

By the way. I bought that cable by around 14€ here: https://www.ebay.es/itm/Macbook-Pro-A1286-2011-2012-821-1311-A-Wifi-Bluetooth-Airport-Card-Cable-New/172242614579?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m2749.l2649

In my macbook pro early 2011 15", the cable was very easy to change. No idea in other models... Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .