4

I'm trying to follow tutorial over at: http://osxdaily.com/2015/06/11/make-bootable-os-x-el-capitan-beta-install-usb-drive/

to create bootable usb for El Capitan Public Beta, however after completion I get this error in console:

Mount of outer dmg failed.

I tried running

hdiutil verify /Applications/Install\ OS\ X\ El\ Capitan\ Public\ Beta.app/Contents/Resources/createinstallmedia

And it returned:

hdiutil: verify: unable to recognize "/Applications/Install OS X El Capitan Public Beta.app/Contents/Resources/createinstallmedia" as a disk image. (image not recognized)
hdiutil: verify failed - image not recognized

I'm not sure why. I downloaded beta installer and it launched correctly. It sits in Applications folder.

5

I tried many things talked about here and on other top Google searches:

  • Redownloaded (three times)
  • Tried moving the .app to Desktop
  • Changed permissions of .app
  • Verified the .dmg with hdiutil
  • Used different Mac

Eventually got it to work by using a different USB flash drive. My original USB was a 16 GB Kingston, the second I tried that also didn't work was a 8 GB Lexar. The third and final one that did not get the "mount of outer dmg failed" error is a PNY 8 GB.

For reference I used the command:

sudo /Applications/Install\ OS\ X\ El\ Capitan\ Public\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan\ Public\ Beta.app --nointeraction

2

I was having this too. I finally had success by copying the install app/folder from /Applications to the desktop. Once there the "mount of outer dmg" message was no more, despite using the same command (other than the appropriate path changes). Might not be the solution for everyone, but it did work for me.

1

The only way I was able to get it to work with my SanDisk Extreme 64GB was to format using 'Apple Partition Map' instead of 'GUID Partition Map' before running createinstallmedia.

  • This is what worked for me too. I tried and got the "mount of outer dmg failed" error with many different USB drives, on multiple Macs and re-downloads of the installer. Switching to 'Apple Partition Map' finally got it working. – Andrew Janke Jul 24 '15 at 21:18
0

What you're trying to do is verify the integrity of the electronic software delivery (ESD) image. But you somehow got it wrong, it should look as follows:

hdiutil verify /Applications/Install\ OS\ X\ El\ Capitan\ Public\ Beta.app/Contents/SharedSupport/InstallESD.dmg

For me the integrity is checked ok, still I have the same error as you:

Mount of outer dmg failed

0

For me it was a permission issue. I copied it to Desktop and ran this command and it fixed the problem:

sudo chown yourusername -Rv ~/Desktop/Install\ OS\ X\ El\ Capitan\ Public\ Beta.app

Copying to Desktop might not even be needed.

0
  • Redownloaded 2 times
  • Tried a different mac
  • Tried changing the format to Apple Partition Map None of these worked, I am going to try DiskMaker and keep my fingers crossed. If you have any suggestions just post them. Also can some one please post the code to install it from a location on the desktop not the Applications folder. Thanks!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .