0

I have a 2012 Mac Mini Server with two internal SSDs. Until recently, I had Mt. Lion installed on one of the SSDs, as my only boot drive, and used the other, rarely, for file storage.

I created a bootable multi-OS USB installer. I completely erased the 2nd SSD and installed Yosemite on it from my bootable USB. I used FileVault 2 to encrypt the drive.

All seemed well, but when I fired up Disk Utility from the Mt. Lion drive, I saw that the main Yosemite partition was listed in duplicate. The duplicate partition seems to be in name & size only and does not appear to have any content on it. Running 'Verify Disk', told me that the main partition was the 'Incorrect size' for its volume and 'Problems were found with the partition map which might prevent booting'. The EFI partition turned red & warned, 'Error: Incorrect size for logical volume.Verifying volume “disk1s1” Verify volume failed: Unrecognized file system.' No errors were noticed with the duplicate main partition.

Assuming I'd somehow screwed up my multi-OS installer, I wiped the Yosemite drive and reinstalled from Internet Recovery.

Again, everything seemed fine, but Disk Utility is giving me the same error warnings & the main Yosemite partition still has this ghost duplicate.

I noticed that my Time Machine backup drive was creating two backups for the Yosemite drive; one was the drive prior to the erase & Yosemite install & the other, with the same name, was the Yosemite install. I removed the entire drive from being able to be backed up by Time Machine & it is now creating backups of only the Yosemite drive prior to the Yosemite installation.

What's going on?!!!?

Is the Yosemite EFI partition actually corrupt? It starts up and runs just fine.

Why does the pre-Yosemite drive have a duplicate and how is the content that was on that drive prior to being completely erased twice still being backed up?!

What do I need to do to actually wipe this drive and have an EFI partition with a recognized file system & no other errors? Could I be getting the errors simply because I'm looking at an encrypted boot drive from a different boot drive? When I run Disk Utility from the Yosemite drive, no errors pop up at all....

I'd appreciate any help or suggestions.

Thanks

EDIT: I unencrypted the Yosemite drive &, when running Disk Utility from the MT. Lion drive to look at the Yosemite drive, the errors & ghost drive have seemingly disappeared. However, I assume that re-encrypting it will result in the errors returning; what needs to be changed to avoid that? Please, see below screen shots of the current Disk Utility drive list, followed by the Terminal results of diskutil list and diskutil cs list. (something weird is going on with imgur)

Disk Utility Drive List - http://pasteboard.co/1QybDvT7.jpg
diskutil list - http://pasteboard.co/1QyeETiD.jpg
diskutil cs list - http://pasteboard.co/1QyhbbFa.jpg

EDIT 2: I re-encrypted the Yosemite drive and all the problems returned. I've taken screengrabs of the information Disk Utility gives when looking at the encrypted Yosemite drive from the Mt. Lion drive.

Ghost Partition - http://pasteboard.co/1QDZ1mo1.jpg
Invalid Disk Label - http://pasteboard.co/1QE1JFH7.jpg
Verify Volume Failed - http://pasteboard.co/1QE3hYbE.jpg

  • Can you paste the output of the diskutil list and diskutil cs list terminal commands? – the eels have eyes Jul 10 '15 at 2:16
  • eeleye, I added links to images & new info to the original post. – Kerlix Jul 10 '15 at 5:38
  • So the drive in question is showing up as disk1? What's with the symbols instead of human readable names? If it is disk1, please paste the output of gpt show disk1. You'll need sudo on the front of that if not booted to recovery. – the eels have eyes Jul 12 '15 at 4:24

You must log in to answer this question.

Browse other questions tagged .