0

I use an iPad Air 1 (8.4) and a MacBook Pro mid 2014 13''(10.10.4)
Whenever I try to connect my iPad to my MacBook with a lightning-usb wire it starts connecting but then disconnects immediately. This process is repeated multiple times a second and even crashes my MacBook.

As a result, I can't move the mouse or write with the keyboard anymore. Animations, slideshows or videos still continue in the background, but even after I close the display and open it again, only the cursor for the password input blinks, but I can't enter anything. Hard-reset is the only way to recover the MacBook.

The iPad behaves like nothing happened and just continues working.
Sometimes it just holds connection for a minute but that's only very few times.

I tried with different 10.10s and wires, but it never works.

As it turns out, it's a specific problem of one USB port go my MacBook, which usually works just fine, but now causes trouble.

1

It's likely that there is a fault with the connector either in the computer, or the cable, as you say you've tried another port and it's working I would suggest that there is a fault with that port.

Do other devices have similar intermittent disconnection issues?

As the USB bus on most modern computers also supports the keyboard, trackpad, FaceTime/iSight Camera and the SD Card reader it's likely that the USB device rapidly connecting and disconnecting dozens of times is causing either a software issue in the kernel extension that manages USB devices, or causing the hardware to shut down the USB hub in the machine to protect it from damage.

Either way, I would suggest trying with a couple other devices, and also check with another Lightning Cable for your iPad and if the issue persists seek service at your nearest Authorised Apple Service Provider, such as an Apple Store.

  • Already checked another cable and the port normally works fine with other devices, too. – Gabkano Jul 10 '15 at 13:05
0

After a broad search, I found this solution which worked for me:

On the iPad tap Settings > General > Reset > Reset Location & Privacy. This will reset your location and privacy settings and require you to set up a trust relationship with the PC/laptop again.

But if you are running out of options ... try that and see if it works. I realize this thread is older, but posting this solution here in case it helps other people.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .