18

The problem is that the WiFi on my MacBook is so slow it is almost unusable, it can be compared to an EDGE connectivity. My iPad and Nexus 4 both work good and have no problems with WiFi and signal is strong even though I'm two rooms from my router. Anyone has an idea of what the problem could be?enter image description here

3
  • 2
    many ideas, so help us by providing following info: Hold the "alt" key then click on the WiFi icon. Now note/report the RSSI, the Transmit rate and the MCS index. Usually is something simple as channel crowding, so changing the channel on the router solves that.
    – Ruskes
    Jul 8, 2015 at 17:08
  • Here you go! hope it helps
    – Daniele C
    Jul 8, 2015 at 17:43
  • 2
    Thanks, first change the Channel (on the FritzBox), from 1 to 5 and test. Your MCS is 0 (zero), it should be minimum 3 or more.
    – Ruskes
    Jul 8, 2015 at 18:00

4 Answers 4

17

Your MCS is zero (0) which would explain why your WiFi is slow.

That can happen if there is channel crowding (not only from your devices but neighbors included).

You could just change the channel for now 1 to 5 and try.

Or you could do a quick analysis of the channels do following:

In Spotlight type "Wireless Diagnostics"

Click on Wireless diagnostics to start it.

Now in the menu bar click on the Window - Utility - WiFi scan -Scan Now.

Sort the result by channel so you can see how crwoded are the channels.

Open your FritzBox set up page and set it to the least occupied channel.

If you do not know how, open any of the following Internet Explorer, Google Chrome, Mozilla Firefox, Safari.

In the address window type 192.168.178.1 , that should open the FritzBox set up page.

5
  • Channel crowding was my problem, as suggested changing the channel (from 1 to 5) improved things immediately. @Allans answer is also worth hindering. Feb 12, 2016 at 8:50
  • Thanks man. This is the only thing that has worked for me after I wasted my entire day trying different solutions. Restored my mac, didn't work. Is this a permanent solution or should I change my router? Also, is the amount of devices connected to the modem the root of this issue?
    – Anon
    Sep 21, 2016 at 15:14
  • What is MCS and what does the value mean?
    – LWZ
    Nov 30, 2018 at 4:00
  • @LWZ let me google that for you controleng.com/articles/…
    – Ruskes
    Nov 30, 2018 at 4:22
  • 3
    I don't understand from this answer why only the MacBook pro was affected, and not other devices. Jul 5, 2019 at 10:42
3

The fix provided by Buscar is a good one, but it's only temporary.

Channel crowding is a problem that will only become worse, not better. As more and more people buy wireless routers, range extenders, and additional access points to solve their connection issues, you are going going to run out of channels.

Manually setting your channel today will fix the problem now, but tomorrow when the other wireless routers with their "Auto Channel Setting" suddenly take over the one you have set up, you are back to square one.

There are a couple of things to look at:

  • Get a dual band (or even tri-band) router. This will give you many, many, more channels to work with. The upside is that the 2.4GHz frequency will easily go through walls, but it will be very crowded. The 5GHz frequency will be relatively quiet (for now), but has more difficulty going through walls. You said you are only two rooms away...5GHz should be able to get to you with no problem. The downside is that they are pricey. Prices start at $150.
  • Run a CAT5e cable. For the price of a high quality router, you can run a CAT5e drop between the two rooms with the cable in the wall. Don't run a 50 or 100 foot patch cable. Put in some plenum rated CAT5e and terminate properly. This will give you a nice, solid gigabit connection.

I personally have done the latter because I had the exact same problem as you are experiencing.

I have a Surface Pro 3 and a iMac that have CAT5e connections on my desk and I have zero connection issues. When I do a scan of my Wi-Fi, I have about 20 different networks all fighting for space (I live in a condo)

Even if you want to "float around" with your MBP and not be tethered to a cable, you can still run the cable and hook up an inexpensive router or WAP, turn down the transmission power of the antennas and ensure a good WiFi network in your room only. (I've done this in the bedroom for the Kindle)

One big benefit is that the gig connection between my computers and my Synology NAS means super fast file transfers. What used to take 10+ mins to copy now only take a few seconds.

2
  • Since there are 15 channels it will take a while before i run out. Thanks for the answer anyway
    – Daniele C
    Jul 9, 2015 at 6:50
  • 2
    But you can't really use those 15 channels, since for example if you choose channel 6, WiFi actually in addition uses the surrounding 4 channels: 4+5+ 6 +7+8 at the same time. That's just how it works. That's why on 2.4 GHz in practice you'll use channels 1, or 6, or 11. May 23, 2018 at 5:13
0

This is a bit stupid but I always connect my workphone to charge it and iTunes asks every time if I want to allow the phone to connect to my Mac. I always select no and did so today also. But somehow it still connected to internet sharing over usb and prioritised this over our office wifi..

I only realised after removing the wifi to add it again, I still had internet :P After disabling internet sharing on my phone it became fast again :P

1
  • 1
    In Network Preferences you can click the little cog then choose Set Service Order. This will allow you to ensure WiFi always takes precedence over USB etc.
    – BlueC
    Sep 30, 2019 at 8:44
0

My router doesn't have an option to change the channel, but it allows for splitting the wifi to two seprate bands - 2.4ghz and 5ghz from a signle 2.4/5 one. 2.4ghz is as slow as before, but 5ghz is super fast! This would suggest that my 2.4ghz band is indeed channel crowded...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .