1

I was trying to make an NTFS hard drive writable on my macbook. I tried the way mentioned in this link: https://www.maketecheasier.com/write-ntfs-partition-os-x-yosemite/

Now I can make changes on my hard drive. But there is another problem. After unmounting - mounting the hard drive, now I can see it only in Volumes folder. I can't bring it back to sidebar or desktop.

I tried other hard drives, they work normally.

Thanks in advance!

Note: I have 10.10.4 installed.

1

This is expected behavior. You specifically told it to not show up in your fstab file, with the "nobrowse" parameter. If you want it on the desktop to have a quick shortcut to it, create a symlink.

ln -s /Volumes/VOLUME_NAME ~/Desktop/VOLUME_NAME  
  • Thank you so much! Is there any other way to make it behave normal (removing "nobrowse" parameter) but writable? I think I need those 3rd party apps.. – iamkaan Jul 8 '15 at 14:11
  • No. Every time I remove "nobrowse" on NTFS it stops being writable. I would try a 3rd party app and see if it does what your looking for. – tron_jones Jul 8 '15 at 14:50
-1

have you tried verifying and repairing disk and permissions for your external HD by using disk utility? If not, open disk utility. Your external disk probably will be shown up at the left. Select it and first repair disk permissions. And also verify disk as well from here.

disk utility

  • repair permissions only works on files that come from Apple - and so not on external disks especially NTFS ones – Mark Jul 8 '15 at 12:04
  • yep, as @Mark said, it doesn't work for NTFS /: – iamkaan Jul 8 '15 at 14:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .