2

In Preferences > Profiles > Keys I've mapped cmd+1 through cmd+9 but cmd+1 alone does not respond.

Does anyone else have this issue?

This is for the latest iterm2, v2.1.1 and several earlier versions as well; it has never worked for me.

1

If you look at the OS X Keyboard Shortcuts, you will see that the keystroke Command-1 through 4 are already assigned to finder which means 5 through 9 are available for mapping.

And speaking of which...OS X once allowed you to create your own mappings and that feature seems to have been conveniently removed. I reccomend taking a look at Karabiner which will not only allow you to remap your keys, but also change all the related settings. Karabiner should allow you to change the mappings of Command-1 through 4 as well.

1
  • Karabiner seems great. I havn't actually created the keymap I need yet, just looking through docs. I'd like cmd+1 to map to ctrl+b 1 for tmux. – Jakl Jul 8 '15 at 17:45
4

The problem is that iterm2 uses cmd+1, cmd+2 ... etc for switching between tabs by default. As long as you have first tab, cmd+1 is binded to switch to the this tab.

Workaround is to change Keys -> Navigation shortcuts -> To switch tabs: value to alt or any other except cmd.

1
  • This is the correct answer. – jameh Apr 9 '18 at 8:37
1

I haven't used iTerm but it sounds like the cmd+1 might be used somewhere else in your system. Try looking inside System Preferences > Keyboard > Shortcuts and look around to see if the shortcut you want to use is already taken by the system or another application.

-1

iTerm2 → Preferences → key → Navigation Shortcuts → To switch split panes. Replace it with other keys, then ⌘ cmd 1 will work.

1
  • 2
    How does this differ from an existing information with the same information? – nohillside Jul 22 '17 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .