29

(Updated answer choice for High Sierra. See the old answer if you are still on Yosemite)

I'm running OS X Yosemite, and I want to disable the notifications from Time Machine. I rarely do a hard-drive backup because all of my essential files are in the cloud. I don't need to run timemachine as often as it suggests/warns/annoys me about.

How do I disable the notifications? Time Machine is not in the Notifications preferences, and I don't want to stop using it entirely.

2
  • Remember one backup is not sufficient Time Machine and in the cloud is probably the minimum
    – mmmmmm
    Apr 19, 2016 at 19:24
  • On Big Sur, I get the message "Connect to a power outlet while your backup disk is available", which is bizarre because I AM connected to a power outlet, and there is NO backup disk available
    – Alan
    Jan 11, 2021 at 18:15

2 Answers 2

10

As mentioned previously, the process to disable these notifications has slightly changed as of High Sierra.

I'm on 10.13.2 and here's the process that I followed:

  • After unchecking Back Up Automatically in the System Preferences > Time Machine section, I was still receiving the messages.
  • I also went ahead and removed my old backup device from Select Backup Disk... and then the warnings have stopped coming up (fingers crossed).
4
  • 4
    It's too bad you can't just leave the disk set up and turn off the notifications. I just don't care that much about backups since most of my stuff is in the cloud.
    – pixelfairy
    Mar 5, 2018 at 22:03
  • AHA. It now seems more obvious that I kept getting this message because I had an old backup disk that I no longer used. However, it needs to be made more clear that that's the reason for the notifications.
    – T3db0t
    Aug 6, 2018 at 15:37
  • 3
    This doesn't answer the question. This answer is like answering the question "how do I disable the dome light on my car" with "just set the car on fire! then you won't have to worry about it anymore." I'm not looking to be without a car I'm looking to configure it to my preferences.
    – joar
    Mar 29, 2021 at 22:32
  • lol @joar ... just set your computer on fire and you won't get the notification (hope you backed up though!) but, seriously, it's annoying to be nagged daily about a backup when you really only need to be reminded occasionally. If it makes you feel better Submit a version of this answer (if there is no better way) along with instructions on setting up a recurring calendar event to backup.
    – pixelfairy
    Apr 13 at 7:02
17

When you don't have the external hard drive hooked up, go System Preferences >> Time Machine, and switch it to OFF. You will still be able to perform backups, it just won't happen automatically.

In newer OS versions, you must uncheck the Back up automatically box and then right-click on the backup disk on the right side and select Stop using ‘Time Machine’ Backups.

This is the technique that I use, and I don't see notifications.

8
  • Thanks! So simple... I guess I didn't realize that I could turn it off. I thought it was doing some sort of local cataloging as well.
    – pixelfairy
    Jul 7, 2015 at 1:55
  • Actually, it looks like it is storing history locally. I can go back to yesterday, last week and many other points in the past that were not back-up remotely.
    – Esteban
    Aug 22, 2016 at 14:06
  • 10
    This option is gone in High Sierra. Oct 28, 2017 at 14:41
  • 9
    The option is still (sort of) accessible by unchecking the “Back up automatically” box and then right-/ctrl-clicking on the backup disk on the right side and selecting “Stop using ‘Time Machine’ Backups” (then confirming). Here’s a little video walkthrough I made: giphy.com/gifs/3ohs7GEcBTTYdOA8sU Nov 16, 2017 at 21:19
  • 1
    OMG life savior, this helps a lot. That right click is so sneaky. How could possibly know lol
    – Eddie
    Nov 22, 2017 at 2:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .