I have a Macbook Pro 15" running OS X 10.6.8. When not connected to an external monitor, launching Terminal looks like this. Note the width of the text (almost looks bold). enter image description here When connected to my 24" Dell 2408WFP monitor (via Mini DisplayPort to DVI connector), launching Terminal looks like this. Note the skinny non-bold appearance of the text. enter image description here Even more odd is Terminal decides on the text style depending on when the app was first launched. If Terminal was initially launched with no external monitor connected, it uses the bold style. If I keep Terminal open and hot connect to my Dell monitor, all subsequent new Terminal windows will use the bold style. If I exit Terminal and relaunch, it uses the skinny non-bold text.

This behavior is really annoying as I prefer the non-external monitor bold appearance.

Oddly, at work I have an iMac connected to a 24" Apple Cinema Display and all Terminal instances uses the bold style text. I suspect Terminal on startup is detecting the monitor(s) and doing something to the text style.

Is there anyway to disable this behavior?

Follow-Up: I'm seeing this behavior in other applications such as iTerm and Firefox. I suspect it's a operation system issue.

1 Answer 1


After some searching, this appears to be a known issue. OS X somehow isn't fully aware my Dell monitor, and is not applying the same font smoothing. The font smoothing can be set using:

defaults -currentHost write -globalDomain AppleFontSmoothing -int 2

See this superuser and macrumors threads.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .