When playing some TV shows on Netflix on a new Apple TV, sometimes the show does not start playing. I get the spinning pinwheel for a "normal" period of time, then a black screen. If I press select, I can see the playback progress bar shows the proper length for the show I selected, but the only command it responds to is Menu.

If I switch over to the Roku that this the Apple TV is replacing, it can stream the same episode just fine. Ditto if I try streaming it over the Xbox or Blueray player.

Things I've tried

I've changed from Google's DNS, back to my ISP's (Time Warner), to OpenDNS and back to TWC's with no improvement. (on suggestion that the geo location was confused)

Tried switching from DHCP to static allocation, no improvement, so I switched back. During the process, I think I power cycled it 4 times or so and then it started playing.

Set Up

Apple TV -HDMI->    TV 
         -TOSLINK-> Receiver
  • WiFi to Linksys WRT130 over N
  • Road Runner 10Mbit (when it isn't raining)
  • Similar problems here. I switched to a wired network connection for the AppleTV and now hardly ever see the pinwheel. I still get a message saying the content is not available (can't remember exact msg) about once a week, this goes away with power-cycling the aTV and/or router/gateway, then the content plays just fine. Never have problems with Netflix on my MacBook Pro. Great Netflix interface on the aTV, but kind of a drag to have to get up off the couch to power cycle. BTW, make sure your aTV software is up-to-date.
    – Phil M
    Commented Jul 31, 2011 at 20:38
  • FWIW you can restart the Apple TV from the remote. At the top level menu, hold the middle button and down for about six seconds. Saves you from all the unplugging/replugging.
    – Gauzy
    Commented Jul 31, 2011 at 21:11
  • @Phill M: I've never gotten any prompts or error messages about content not available, just nothing which was really strange. As for wired, the only thing I have is an Airport Express behind the cabinet for the Xbox (cost the same as the Xbox adaptor at the time). I'll give that a try next time it barfs.
    – mwalling
    Commented Jul 31, 2011 at 21:57
  • @Gauzy: I learned that. There's also a menu+down command you can send too apparently.
    – mwalling
    Commented Jul 31, 2011 at 21:58
  • Try another router. Commented Dec 17, 2012 at 13:36

2 Answers 2


So I took the first ATV back to the Apple Store, and had a repair by replacement. It still had problems, so I started digging deeper.

Through some more specific testing, I narrowed down that it was only happening with movies that had Dolby Digital. In the settings, I had forced the Dolby on in the settings. Turning that off fixed it. It is still stable with Send data to Apple turned on, and switched back over to Google DNS.


I was having similar issues, using my ISP's DNS. What worked for me was disabling "Send data to Apple" in the settings.

  • I'll try this next time it crashes. You're the closest thing to a lead I've had.
    – mwalling
    Commented Jul 31, 2011 at 21:59
  • Could be coincidence, but after doing this there were no interruptions. Thanks.
    – mwalling
    Commented Aug 3, 2011 at 11:49
  • Glad it helped:) Not sure why it does, but it does.
    – Gauzy
    Commented Aug 3, 2011 at 19:06
  • I did some more "scientific" testing... see my answer for the result.
    – mwalling
    Commented Aug 27, 2011 at 21:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .