11

Recently bought a new Macbook Pro to replace an older Air. Everything is working great except for the Amazon Music app. It downloads and installs just fine, but when I try to launch it using Spotlight, double-clicking in Finder or right-click + "Open" in Finder...nothing happens. The system log reports that:

com.apple.xpc.launchd[1] (com.amazon.music.87788[14329]): Service exited with abnormal code: 1

Not very helpful. I've tinkered with the Security & Privacy settings (i.e. "Allow apps downloaded from"), but that changed nothing. I've tried uninstalling the app and reinstalling it via Homebrew Cask. Nothing. I've tried un/re-installing the app various ways multiple times. Nothing.

The interesting part, and perhaps a glimmer of hope, is that if I flip over to the Guest user, I can open the app just fine.

Anyone have any idea what might be going on with my user account that would be impacting my ability to launch a particular application?

19

I just experienced the same symptoms. I resolved it by deleting ~/Library/Application Support/Amazon Music. The only file in that directory was a file called i18nUpgrade.txt with the contents Upgrade to i18n build.

  • I can't believe I never checked ~/Library/.... I'm pretty sure I checked /Library/..., but I guess I put too much faith in AppTrap. Damn, I can't believe it was that easy. Thanks! – Rob Wilkerson Aug 5 '15 at 3:16
  • 1
    This finally fixed the issue for me (after a couple of months of trying). I could totally have your baby right now. – Richard Clayton Oct 22 '15 at 16:20
  • 1
    It's important to note that you must delete the directory itself and not just the contents within. rm -rf ~/Library/Application\ Support/Amazon\ Music/ will do it from the terminal. – bstempi Dec 3 '15 at 16:04
  • I removed the i18nUpgrade.txt file, but it was the other stuff from an earlier version that seemed to cause an out-of-memory condition. – Otheus Oct 6 '18 at 15:49
  • For the 2019 version, I also had to manually create the Plugins folder in the app Content directory (found from the errors in console). – FGM Mar 26 at 11:28
3

I had the same issue on my new Macbook Air (replacing an older Macbook Pro), with the same Console message.

Deleting the app and reinstalling had no effect, and deleting ~/Library/Application Support/Amazon Music had no effect.

What eventually worked was to delete / uninstall with AppCleaner and reinstall. The files that AppCleaner identified:

  • /Applications/Amazon Music.app
  • ~/Library/Application Support/Amazon Music
  • ~/Library/LaunchAgents/com.amazon.music.plist
  • ~/Library/Preferences/com.amazon.music.plist
2

Deleting i18nUpgrade.txt didn't solve my issue. So I've deleted the entire ~/Library/Application Support/Amazon Music folder! And ... da da da ... Amazon Music starts and ask for login data :-)

  • This solved things for me rm -rf ~/Library/Application\ Support/Amazon\ Music – SoluableNonagon Nov 26 '18 at 17:08
1

For what it's worth, I found that the Amazon Music Helper app was refusing to quit and prevented me from reinstalling over the app. Activity Monitor revealed that the helper was housed in the app itself. I deleted that and was able to reinstall the newest version.

  • This worked for me too. Shut everything down, delete the installer and the download image, then restart the app and it works. Good lot of QA they did on that one. – JohnMetta Oct 31 '16 at 18:20
0

This may not be much of an answer, but I have also had issues with 3rd party apps while using a MacBook Pro. Here are a couple things you could try:

1. Make sure the application is capable of running on your Mac version. [E.g; if your computer can handle 32bit applications or 64bit] Check Amazon's website where you downloaded the application to see if they have different versions. Alien Skin has an article on how to make an application run 32bit, if it's supported by the app.

2. Is your computer running the right OS X? [The app may only support 10.9 and above or something specific like that.] Again, check Amazon to see if they have specific versions of the app. https://support.apple.com/en-ca/HT201260 - Find the OS X version and build information on your Mac

3. Check if the app is in the Mac App Store. [The App Store version might open without difficulties.]

  • In this case, it's the Amazon Music app which isn't available in the App Store. This same version of the app runs fine on my MBA which is running Yosemite, same as the new computer. I've inspected permissions and all looks well there too. At this point, I'm at a loss. – Rob Wilkerson Jul 5 '15 at 23:27
  • I'm going to edit your links - better to describe them - expose that they are Apple Support Articles IMO. – bmike Jul 9 '15 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .