5

On Yosemite 10.10 Onyx returns the following error:

Error: -69845: File system verify or repair failed Underlying error: 8: POSIX reports: Exec format error The disk needs to be repaired.

I tried repairing the disk in recovery mode but the disk utility returns a message that everything is fine, however, the after running Onyx the second time the error persists.

On a related matter, the option to repair permissions is not available in the Disk Utility.

  • 1
    Same issue. I'm keeping an eye on this one. – bjbk Aug 16 '15 at 18:06
  • Out of curiosity and trying to trouble shoot for both of us, what is your current hardware? Mine: MacBook Pro (Retina, 13-inch, Late 2013) 251 GB Flash Storage. – bjbk Aug 16 '15 at 18:16
1

I had the same issue. I was able to fix it in an interesting way.

I have been testing El Capitan on an external drive. So, I thought, why not try Disk Utility using OS 10.11.x and (after the second pass) it repaired the drive. As the Beta was on a separate disk, and the Macintosh HD was unmounted at the time, it was analyzed and repaired. Just like using a 3rd party app.

At least this was a "free" way to fix it. Saved the hassle of reformatting and restoring.

2

Disk Utility will not fix every conceivable disk corruption issue. For that you need third-party apps. I use Diskwarrior and have also had success with Drive Genius.

However there is one way to do this without buying a disk repair utility. Back up your hard drive, partition/reformat it, reinstall the OS and restore your backup. Yeah it's more complicated and a bit of a PITA but will save you money.

  • Thanks, I came across similar post and it appears that the DW is a highly recommended software. I was hoping that the error number 69845 would help to identify the problem precisely. – Konrad Jul 5 '15 at 14:17
1

This was a problem for me too. I booted from an external disk (USB stick in fact), ran disk utility, then Onyx found no problems.

0

It because Disk Utility doesn't recognize all errors.

I had the same issue before, and I fixed it by following the instructions on the onyx's Known Problem page and this guide to run

fsck -fy

under Single User mode

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .