3

I have two hard disks on my 2012 Mac Mini. The first disk is partitioned with Mac HD and Data HD. The second drive has OS X Public Beta and Windows partitioned.

I want to prevent OS X on my main disk from auto-mounting OS X Public Beta and Windows 7. Both are encrypted (FileVault 2 and Bitlocker).

I tried to edit /etc/fstab and /private/etc/fstab which seem to be replicated but it doesn't work. I thought I was doing something wrong, so I added a line for Data HD which is not encrypted and it didn't mount.

sudo vifs

UUID=NUMBER none hfs ro,noauto

That's the line I'm issuing for Public Beta. I'm assuming its not hfs because of FV2 so is there another file system I need to enter? I also tried hfs+ and it didn't work, I still get prompted to enter passcode.

For Windows 7, I'm assuming I would use ntfs? I'm not using BootCamp so I don't think it would be fat.

  • Why don't you just keep the drive turned off until you need the Public Beta or Windows? – nohillside Jul 3 '15 at 6:45
1

Instead of using UUID try using LABEL. This will help to rule out UUID problems.

The following line in /private/etc/fstab stops the drive named SpareSSHD from mounting on OS X 10.10:

LABEL=SpareSSHD none    hfs rw,noauto

My drives are encrypted with FileVault2 and this works.

The following links provide more detail:

/private/etc/fstab and /etc/fstab are the same file. As @forquare confirms, they are symlinked. You can edit either.

  • You are correct they are the same file, /etc is a symlink to /private/etc as you can see here: lrwxr-xr-x@ 1 root wheel 11B Oct 20 2014 etc@ -> private/etc – forquare Jul 3 '15 at 12:51
  • 1
    I'm on OS X 10.11.1 with a configuration like this, and it isn't working for me. I tried using the LABEL form, with the "Volume Name" from Disk Utility, and all the UUIDs associated with it. I still get a "Enter a password to unlock" prompt upon login, though this fstab change prevents the disk from actually mounting once I enter the password to unlock it. Is there another way to do this? Or something else that needs to be used for the LABEL? – Andrew Janke Dec 4 '15 at 1:41
-1

Try 'xx' instead of rw or ro. Since a FV2 drive doesn't mount until you unlock it, the rw,ro won't do anything.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .