I have my iMovie events stored on my external harddrive (located in a Synology NAS). It worked like a charm with iMovie '11 on Snow Leopard.

I then received my new MBP with Lion and the external drive is not showing. I cannot thus access my events which is pretty annoying as it prevents me from using the application...

Here is what I see in iMovie:(see edit 2 for new state)
I previously had my external drive below the Macintosh HD one.

My external drive is correctly mounted before launching iMovie:
mounted HDD info

It has the iMovie Events folder at root level (and as I said, it was correctly detected under same iMovie version on Snow Leopard).

I tried mounting it using afp: but result is the same.

Any help appreciated as I don't get what could have changed between SL and Lion for this.

edit: Same with volume now mounted using NFS:
NFS Volume

The list in iMovie stays desperately empty...

edit 2: something new! My NFS mounts are now visible in the list (probably coming from an update of iMovie inbetween).
Problem is that they are still empty and with a yellow warning sign, without any tooltip on it...
enter image description here


Lion turned off an older and less secure method of authenticating AFP connections, which a lot of third-party vendors of NAS devices were using, including Synology. Synology have made available a beta release of their new firmware which fully supports Lion (as long as your Synology device was made in 2008 or later).

  • Before posting I upgraded my NAS to the last 3.1 DSM version not seeing there were a 3.2 Beta. I'll try this one. – LudoMC Jul 31 '11 at 16:42
  • Upgraded to 3.2 beta and still the same issue. When mounted (afp or smb) drive is not showing up in iMovie... :( – LudoMC Jul 31 '11 at 17:31
  • 1
    Now upgraded to final 3.2 version for my NAS and still the same issue (afp, smb or nfs) – LudoMC Sep 10 '11 at 12:28

OK, I did me a nice christmas gift by solving this, and quite easily in fact.
It could be considered as workaround only but it saved my life.

Answer: symlink!

Now, in my Movies folder, the iMovie Events folder is pointing to the iMovie Events folder I have on my external harddrive. All my videos are back and I can add videos without issue.

So waiting for the trick to get it work how it should, at least, I can use the application again!

You must log in to answer this question.

protected by Community Oct 12 '11 at 4:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .