1

I have a Macally Wired 3 Button Optical USB Mouse ("BUMPER MOUSE") plugged into my iMac running Mavericks. When I put my iMac to sleep, the screen goes dark, but after about 10 seconds, the red LED on the bottom of the mouse flashes rapidly for about 5 seconds, then the LED turns solid for about 2 seconds, and then the iMac wakes up.

An entry in the syslog confirms that the Macally mouse is issuing a "remote wakeup" signal:

Jul 1 21:51:55 imac kernel[0] : Wake reason: EHC2

Jul 1 21:51:55 imac kernel[0] : The USB device HubDevice (Port 1 of Hub at 0xfa000000) may have caused a wake by issuing a remote wakeup (2)

Jul 1 21:51:55 imac kernel[0] : AppleThunderboltHAL::earlyWake - complete - took 0 milliseconds

Jul 1 21:51:55 imac kernel[0] : 169.011637: ar9300WowWakeUp: Skip PCIE WA programming

Jul 1 21:51:55 iMac kernel[0] : The USB device Macally BUMPERMOUSE (Port 3 of Hub at 0xfa100000) may have caused a wake by issuing a remote wakeup (3)

Jul 1 21:51:55 iMac kernel[0] : full wake (reason 1) 72 ms

I sent an email to Macally Tech Support but I'm not holding my breath....

Is there a setting (or script?) to tell OSX to ignore remote wakeup signal from a USB mouse?

Thanks.

1

No. You'll need to unplug USB devices that wake your Mac prematurely.

This is a firmware level task which would require significant training to pull off. Nothing is impossible, but this isn't an easy setting to simply change.

Hopefully the vendor has a way to make it more like other USB mice that only wake their host when they are physically moved and not for the fun of it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .