1

I have been trying to erase my external Hard Drive "My Passport", however there was a problem and then the Hard Drive disappeared from the Desktop and could't be found. Only Disk Utility would see it but it would't mount it. I tried erasing it and partitioning it, however nothing helped and i'd always get this error: "System Formatter Failed".

I found a few links that worked on previous version of OS X, eg. Link 1, or Link 2. None of those worked, I always would get the error message and could never mount the drive.

3

The solution that works on both OS 10.11 El Capitan and on OS 10.10 Yosemite is:

  1. Open up Disk Utility
  2. Select the actual drive, which is the lower part that will most likely be greyed out:
  3. Then go to Erase
  4. Select MAC OS EXTENDED (Journaled, Encrypted) It's important to select Encrypted
  5. Then enter a password and wait.(It will run without a problem )
  6. Then you can again erase and take the password down and use your drive again.
|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .