12

I "upgraded" to iOS 8.4 and the Music App now has a new icon and different functions. That's awesome, except I cannot figure out how to view my music collection by album instead of by artist.

I tap the MyMusic icon at the bottom of the screen. There is a drop down selector 1/3 of the way down that (when tapped) presents "Artists, Albums, Songs, etc. etc"

When I select Album, it groups by Album, but sorts by Artist. I want it to sort by Album. I'm hoping I'm missing something obvious here, but I cannot figure it out.

  • @azngeoffdog Your edit is being discussed on meta – grg Jul 24 '15 at 20:25
  • I actually opened a bug item on this. Me: "When I sort my music by album, it continues to sort by artist, not album." Apple: "You actually have to go into these deep settings inside your phone and change what should the the obvious sorting of your albums to actually be the actual sorting of your albums, dumbass." Me: "Thanks Apple..." – gh0st Jul 28 '15 at 4:17
14

Go to Settings > Music and under Library check if "Sort Albums" is set to Artists or Title

music settings

Change to "By Title" to sort them the way you described.

sort By Artist / by Title

  • 1
    I actually opened a bug item on this. Me: "When I sort my music by album, it continues to sort by artist, not album." Apple: "You actually have to go into these deep settings inside your phone and change what should the the obvious sorting of your albums to actually be the actual sorting of your albums, dumbass." Me: "Thanks Apple..." – gh0st Jul 28 '15 at 4:17
  • 1
    I wish I could upvote this 10 more times. This has been bothering me for months. – Brent Writes Code Apr 1 '16 at 4:19
  • Not only does this answer the original question, it also has a bonus side effect which relates to a question I was seeking an answer to: in my "Albums" list, a few "compilations" weren't showing up, unless I switched to the Compilations view. I wanted them to show up as albums, though, because to me they are, and I didn't understand why they didn't show. I guess because they had different artists, instead of just picking a sort position, they left them out? I don't know, but making this change caused them to show up. So two improvements with one change! Yay, and thanks! – lindes May 15 '16 at 13:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .