7

iTunes stopped uploading my own (i.e. not from the iTunes store) music after 5Gb out of 50GB. The rest of the tracks have the iCloud status Waiting in the get info box in the File tab.

On my iPhone (iOS 8.4) the tracks appear in my Music grayed out, meaning they can not be played.

Is there some way to reset the iCloud status of these tracks so they can be uploaded?

album iCloud status

Edit: There no option in the right click menu to add it to the iCloud Library. Also if Click Remove download it greys out the track. If I try to play the track, it fails to redownload the track from the cloud, since it was never uploaded.

right click menu

Using: OS X 10.10.4, iTunes 12.2, iOS 8.4

5

Try the menu item File > Library > Update iCloud Music Library.

screenshot of Update iCloud Music Library

I had quit iTunes after initially enabling iCloud Music Library in preferences when it was only partially done uploading. To get it going again I used this menu item Update iCloud Music Library, the progress indicator in the upper right appeared and it continued uploading. This was on OS X 10.10.4 and iTunes 12.2.0.145.

  • This fixed an identical problem for me. Thank you! Clicking on the progress indicator (the "throbbing circle") pops up an info box with upload status, so you can follow the process. – dan8394 Jul 7 '15 at 21:37
  • Kind of works for me. It uploads more tracks, but some of the tracks are still not done. – Bilal Syed Hussain Jul 8 '15 at 12:51
  • Choosing "Update iCloud Music Library" does nothing for me. My songs that are in "Error" state remain so. – Jowie Nov 30 '16 at 10:16
0

Follow these Steps:

  1. Click on iTunes
  2. Click Preferences...
  3. Uncheck "iCloud Music Library (yourappleid)"
  4. Click "OK"
  5. Click on iTunes
  6. Click Preferences...
  7. Check "iCloud Music Library (yourappleid)"
  8. Click "OK"
0

I had to untick iCloud music library, close prefs, then reopen it and it started syncing again. Briefly it also let me right click a song and upload to iCloud music library, but that didn't seem to do anything

Edit:

  1. Click on iTunes
  2. Click Preferences...
  3. Uncheck "iCloud Music Library (yourappleid)"
  4. Click "OK"
  5. Click on iTunes
  6. Click Preferences...
  7. Check "iCloud Music Library (yourappleid)"
  8. Click "OK"
  • I always find the idea of switching off iCloud services and turning them on again a really scary solution, if indeed it does work. For the case of a single song file, you are disconnecting up to 99,999 others. iCloud is flaky enough as it is without trusting that it'll accurately reconnect all my library files without messing up their metadata or getting duplicates. Thanks, but no thanks! – Jowie Nov 30 '16 at 10:14
  • By doing this I got some of playlists duplicated i.e Rock => Rock1 and so on, this could not be a problem if it was to just remove the duplicated lists, but instead some of the songs in it went missing which drive me nuts. – Adriano Rosa Dec 28 '16 at 19:15

You must log in to answer this question.

protected by grg Jul 24 '15 at 18:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .