23

I use Yosemite 10.10.4 on my MacBook Pro (2012).

I used to work with an external monitor: Apple Thunderbolt 27" monitor.

The issue is that, according to Activity Monitor, the kernel_task process consumes more than 600% of CPU even when no tasks are running! The computer becomes totally unusable.

The workaround is to disconnect the external monitor, but I really need this secondary screen to work.

Why didn't Apple fix this issue in the latest Yosemite update?

Is there a fix for this?

  • I have a similar problem with my macbook pro 13" the UserEventAgent , launchd and mds_stores processes suddenly take up 52% of all cpu the instant I plug in my second display. It's not temperature.. nothing gets that much hotter in 0.5 seconds. Literally, have 'top' running in a screen and plug in the thunderbolt/external video adapter and as soon as the screens have come back from their refresh and the windows are visible again you will see that those three processes have leapt to the top and idle time has gone from 97% to 47%. I have heard that the 15inch models had a problem with temperatur – user157566 Nov 15 '15 at 15:07

10 Answers 10

14

This is a design feature documented by Apple. See if cooling your Mac and the processor can then speed up again and do the work you want. See this post on ideas for cooling while in clamshell mode.

You can now buy stands designed to cool your Mac.

If that doesn't work, try resetting the System Management Controller one time to ensure it's not a measurement error.

If you only need occasional cooling or to convince yourself, go ahead and open the clamshell and make sure there is good ventilation and you are not blocking the air inlet or outlet by the display hinges. The thermal management software reacts quite rapidly to changes in internal temperature. could even use Magnets to force the display to sleep while it's actually open and allowing the entire keyboard surface to be exposed and cooling the Mac that thinks it's still working in closed clamshell mode.

Activity Monitor may show that a process named kernel_task is using a large percentage of your CPU, and during this time you may notice a lot of fan activity. This process helps manage temperature by making the CPU less available to processes that are using the CPU intensely. In other words, kernel_task responds to conditions that cause your CPU to become too hot. When the temperature decreases, kernel_task automatically reduces its activity.

So, also quit the other tasks and apps you don't need if you can't make the physical arrangement of the Mac more cool or more conducive to radiating the heat away if convection isn't working for you. The GPU will cause lots of heat if it's pushing many pixels. Decreasing resolution might help in an edge case, but you'll want to attack cooling in general as a first step.

You could also get some advanced tools to peek into the CPU rate to confirm it's reacting to heat:

  • 37 degrees celsius (in Paris) doesn't help...I agree. But why haven't I had this issue when using Mountain Lion? – Mik378 Jul 1 '15 at 16:11
  • 1
    @Mik378 Yes - and glass trapping a thin layer of air is an extremely effective insulator. Just barely wedging open the screen with a shim so that the internal display is still off (sleep proximity sensor detects the magnet in the display) - or better - using a magnet externally and opening the Mac totally are good for very warm environments. Also, WOW 37° in Paris!! – bmike Jul 1 '15 at 16:14
  • But I still need the macbook's monitor. Yes, very very hot week ;) – Mik378 Jul 1 '15 at 16:18
  • 1
    @Mik378 You may have to choose if the temperature can't be lowered. I've used Duet Display to let my Mac run cooler and still have two screens. You'd need an iPad and some $$ to try that though. Maybe now that you know it's cooling you can get by with reducing the GPU heat generation load (decrease resolution) to get more CPU capacity. Also, if you let it sleep for 20 minutes and still see immediate high kernel_task, it might have a hardware issue (bad temp sensor, etc...) – bmike Jul 1 '15 at 16:20
  • Wow nice :) I wasn't aware of this Duet Display application. I own an iPad, so I will try it out. Thanks :) – Mik378 Jul 1 '15 at 16:22
5

My question was marked as a duplicate of this one but has a solution to this issue verified by many users.

rMBP kernel_task spikes when connecting more than one external monitor

:)

  • 1
    This is only working solution. – Sibidharan Mar 30 '17 at 14:47
4

I have a MacBook Pro Retina, 15-inch, Late 2013 2.3 GHz Intel Core i7 16 GB 1600 MHz DDR3 NVIDIA GeForce GT 750M 2048 MB Intel Iris Pro 1536 MB

With an external Sceptre X325BV monitor connected via HDMI. I was also seeing CPU percentages close to 500%.

I did three things that seem to have fixed this:

  1. I changed the laptop's retina monitor to be the main one.

  2. In System Preferences > Energy Saver, I unchecked "Automatic graphics switching."

  3. In System Preferences > Mission Control, I unchecked "Displays have separate Spaces."

Energy Saver Prefs Change Mission Control Prefs chnage

  • Thank you for posting this solution, Mark! The mission control change fixed it for me on my late 2015 MBP11,5 with discrete graphics and dual Thunderbolt displays - didn't have to do automatic graphics switching. I first noticed the problem fairly recently in Sierra and did a clean upgrade to High Sierra, thinking that I had some sort of crufty software that was causing the would solve the problem. But only after unchecking the "Displays have separate Spaces" did the problem go away. I was starting to think I had hardware problems. – NateTheGreat Nov 11 '17 at 0:13
3

I'm having a similar issue with a 2011 13" MBP8,1 (2.7Ghz i7 CPU and HD3000 graphics), and to me it's pretty certain that it's provoked by video-intensive operations. Curiously, Hardware Monitor showed temperatures in the 70C range, quite far from the 90+C temperatures I've already seen while running big compile jobs.

I removed the bottom plate and removed far more very fine dust from the fan and its vents than I'd have expected, and blowing over the logic board dislodged even more. On the 13" model, the fan can be removed with just 3 screws after removing the bottom plate, so it's easy enough to clean (careful with the connector!). I haven't used the system much since, but 1st impressions were that the fan was much more effective again, and that the issue was gone.

Next steps will be running without the bottom plate and reducing my external screen's resolution from 1920*1080 to 1680*1080 (res. of my previous panel with which I never had problems, and a resolution that's clearly easier on the GPU for video playback).

I never understood why anyone would want to connect an external screen and NOT use the "internal" at the same time (saving battery? I just turn off the backlight in that case ...)

2

I have a simpler fix and one that I read on another thread. I doubted this would work but it did! I purchased a USB powered cooling pad for my 15" Retina mid-2012. I use both of my Thunderbolt ports to power two Dell 24" monitors via their Display port connections.

Before I either had to disconnect the secondary monitor or use the lower res HDMI port off my laptop to stop the runaway CPU kernal_task issue. A couple of utilities I used to measure the success of this fix is the native "Activity Monitor" and the "Temperature Gage" app from Tunabelly software available in the Mac app store.

For hardware, I purchased the Cooler Master/X-Slim 160mm-Fan cooling pad on Amazon: https://www.amazon.com/gp/product/B005C31HC0/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

With all of the software fixes I've been reading, I couldn't believe that this would fix my issue but I'll be darn, it did!

1

Have a MacBook Pro (Retina, 15-inch, Late 2013) and was having 300-600+% cpu usage from kernel_task. After reading some speculation online about it being a safeguard to prevent overheating, I started to wonder why my machine couldn't handle outputting to three monitors. Following the instructions here, I looked and saw none of the applications I was running were using the high-end card. After going into System Preferences > Energy Saver and disabling Automatic graphics switching (forcing the high-end card to always be used), the issue seems to be resolved.

1

Had the same issue, when connecting monitors kernal_task would go through the roof and computer became unresponsive.

When disconnecting the monitors, everything went back to normal.

I noticed the base of the laptop was very warm and so elevated it by an inch (using a small box) which resolved the issue.

I can only guess that the exposed surface area was enough to ensure that the machine remained within the acceptable range.

1

I found the same issue in High Sierra connected to a 4K Samsung Curve TV using hdmi and none of the solutions listed worked for me and I didn't want to remove system files.

After some time I found an easy alternative solution which I will share below: (Screenshot in french) External monitor preferences

  1. Open monitor preferences and pick the external window preferences window
  2. By default, OS X will try to define the resolution for you. Override that by switching to manual control
  3. Change to a different resolution, any one will do
  4. Switch back to the resolution you want but manually

Please comment if this worked for you. thanks

1

For me, despite trying many, many different approaches and it taking a full day and a half of my time, the solution in the end was simple: I took a compressed air can and blew out the vents which hide inside the hinge for the screen.

That immediately stopped the fans from being noisy (which I'd not noticed had built up and up over the three years I've owned the machine) and allowed the temperature to come down.

I'd already half-heartedly tried blowing the dust out but apparently hadn't managed to clear it.

Note: Using compressed air is dangerous for your machine. Keep the can upright to avoid liquid coming out. The liquid is cold enough to damage delicate components. Spray in short bursts for the same reason. Also short bursts should help avoid spinning up the fans to some extent, which is thought to be potentially damaging (allegedly, I am not entirely convinced of this danger, but may be wrong!).

A safer and more complete option would be to take the machine to an Apple Genius Bar or other laptop repair place (if out of warranty) and get it opened and cleaned.

I was surprised how unplugging the monitor would immediately result in the kernel_task process dropping back to normal. So the fact that it was purely temperature related wasn't easy to see, since I'd expect more of a lag for kernel_task to calm down as the temperature declined.

I believe that, at least in my case, this is the true fix for the issue.

Note that, as mentioned in some other answers, the behaviour of kernel_task is deliberate: https://support.apple.com/en-us/HT207359 Which says:

One of the functions of kernel_task is to help manage CPU temperature by making the CPU less available to processes that are using it intensely.

1

High temperature in a part of the chassis from charging together with peripherals plugged in can cause this issue, at least on a 2017 MBP. Simply moving the charging cable from the left to the right ports can be enough to cool the hotspot and resolve the problem. On a machine with MagSafe charging try unplugging peripherals from the left ports until the battery is full.

See https://apple.stackexchange.com/a/363933/27135 for proof.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .