1

I'm using Macbook Pro 2012 running Mac OS X 10.10.3 and earlier today, I was trying to install Linux on a USB drive through Terminal. I first converted the format with this:

hdiutil convert -format UDRW -o ubuntu.iso ubuntu-1xxxx.iso

Next, listed drives with:

diskutil list

Added my flash drive. And then ran this:

diskutil unmountDisk /dev/diskN

where N being the no. of drive from the DiskUtil list. Here by mistake I chose the disk0, my boot recovery in my opinion, and unmounted that.

After that I ran,

sudo dd if=./ubuntu.iso of=/dev/rdiskN bs=1m

where again N being the no of drive listed in DiskUtil list. Here again, absentmindedly I chose disk1, the Macintosh HD, in my opinion. And suddenly after that I realized, what was happening and cancelled the process midway.

After that I tried remounting my recovery, but my Mac froze and after I tried to restart i got stuck at the prohibitory page. I tried booting into Recovery with Command+R, and tried mounting my Macintosh HD from there, but it gave me a error, that it couldn't be mounted. It asked me, to check a Disk Verification and Disk repair, I did that on my Macintosh HD and both were okay. But after that also the problem persists and I can't mount the Macintosh HD and still stuck at the prohibitory page.

I want to save my data, and want to backup my Macintosh HD, to an external hard drive.

  • Hi @ritvik1512, Welcome to Ask Different. Please clarify your question, as it stands, it looks as a description of what you did –which probably is the cause of your computer refusing to boot– but it isn't clear what you would like to achieve. Would you like to save your data? Reinstall? Repairing or recovering a partially re-writen partition does not seem to be an easy route. – Jaime Santa Cruz Jul 1 '15 at 15:44
  • 1
    @JaimeSantaCruz I'm looking for ways to backup my Macintosh HD. – ritvik1512 Jul 1 '15 at 16:37

You must log in to answer this question.

Browse other questions tagged .