1

I'm trying to disable and enable the favourite bar in mac os "Yosemite" using bash script, I used the following command in terminal but it didn't work even after I restarted Safari, so am I doing something wrong?

defaults write com.apple.Safari ShowFavoritesBar -bool false
3
  • even after relaunching the app? Otherwise, I'd guess there's nothing to prompt it to read the new setting
    – Tetsujin
    Commented Jul 1, 2015 at 12:58
  • I restarted the app :( Commented Jul 1, 2015 at 13:02
  • defaults read says it doesn't exist. I tested defaults read com.apple.Safari ShowStatusBar for comparison, which does exist
    – Tetsujin
    Commented Jul 1, 2015 at 13:06

1 Answer 1

1

You need to add a -v2 for Yosemite. See below:

defaults write com.apple.Safari ShowFavoritesBar-v2 -bool false

Restart Safari.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .