7

I've notice after I updated my iTunes to 12.2 on my OSX 10.10.4 computers, a very large upload bandwidth has been taken place. This is a result of Apple's new iCloud Music Library feature. I don't want to upload my musics to iCloud, and I found no options to prevent iTunes 12.2 from automatically uploading sound tracks to iCloud Music Library.

I also noticed if I use file > library > Update iCloud Music Library, some of my deleted songs will come back to my playlist. I can delete them but once I click file > library > Update iCloud Music Library again, they will reappear in my playlist.

3
  • You also have to turn icloud music library off from your iphone/ipod/ipad aswell as your mac :)
    – user136787
    Jul 18 '15 at 1:07
  • You ALSO have to go to, on your iPhone, Settings-->Music-->Turn off iCloud Music Library, I also turned off "Show Apple Music" for good measure.
    – user137832
    Jul 26 '15 at 17:17
  • If people want to answer a more holistic - how do I manage things with iOS and Mac, please ask a new question to cover that expanded issue.
    – bmike
    Aug 28 '15 at 18:27
9

To turn off iCloud Music Library on your mac, you need to go to: iTunes>Preferences>iCloud Music Library

3
  • 3
    Is than an update to this answer since the release of Apple Music? I don't see any options for "iCloud Music Library". Jul 22 '15 at 12:04
  • 1
    @JacobMcLock: Which version of iTunes are you using? In 12.2, the "General" section of the preferences has a checkbox under "Show Apple Music" for "iCloud Music Library (your account email)". Aug 5 '15 at 19:23
  • I also don't have the iCloud option on iTunes 12.3.1: cl.ly/image/042R0V0y282y
    – davidhq
    Oct 30 '15 at 16:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .